0

Trying to passthrough a usb mouse with qemu 2.0 fails however I try it. What I have tried so far:

  • evdev passthrough:
    -object input-linux,id=mouse,evdev=/dev/input/by-id/usb-413c_Dell_Premium_USB_Optical_Mouse-event-mouse
  • usb passthrough with xhci emulation:
    -device nec-usb-xhci,id=xhci -device usb-host,bus=xhci.0,vendorid=0x413c,productid=0x3016

I've also tried to pass the whole controller with vfio but with no success. The closest I've got to success was with evdev and usb controller where I can see the mouse in the windows guest device manager listed as HID compliant mouse but I cannot interact with it. The device manager recognize the mouse and says it is working properly but trying to move the mouse around or click through rdp does not work. Unchecking Allow the computer to turn off this device to save power changes nothing.
I'm not using libvirt.
I only have usb3.0 ports on my machine and changing the controller to ehci or uhci does not work either.

Update:
Connecting to the VM via vnc confirms that the mouse redirection through qemu is working however when connecting with RDP the mouse does not work anymore.

Update 1:
It appears that the mouse is only connected to the local session and microsoft disabled rdp to session 0 which would give access to physical session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.