1

I recently aquired a Myria MY8307 laptop/tablet. I decided to give Kali a try but right after installing I ran into a problem. When the login shows up my screen is upside down, and it continues to be like that till I use "xrandr -o left" in the terminal.

Edit: It's not a Kali only thing, I get the same thing on both Fedora and Parrot Sec. So it's the iio-sensor that's causing it.

I tried adding

# Myria MY8307 (MY8307)
sensor:modalias:acpi:BOSC0200*:dmi:*:svnCompletElectroServ:pnMY8307:*
 ACCEL_MOUNT_MATRIX=0, 1, 0; 0, -1, 0; 0, 0, 1

into a 61-sensor-local.hwdb in /lib/udev/hwdb.d

but I can't seem to get it working. I was wondering if you guys could show me what I did wrong.

Running systemd-hwdb update returns no error Running udevadm trigger -v -p DEVNAME=/dev/iio:device0 returns

/sys/devices/pci0000:00/808622C1:02/i2c-2/i2c-BOSC0200:00/iio:device0

The output of dmidecode | grep Manufacturer is

    Manufacturer: Complet Electro Serv
    Manufacturer: Insyde
    Manufacturer: Chassis Manufacturer
    Manufacturer: Intel(R) Corporation
    Option 1: String1 for Type12 Equipment Manufacturer
    Option 2: String2 for Type12 Equipment Manufacturer
    Option 3: String3 for Type12 Equipment Manufacturer
    Option 4: String4 for Type12 Equipment Manufacturer
    Manufacturer: 0000
    Manufacturer: Intel SR 1
    Manufacturer: OEM Define 2

and the output of dmidecode | grep Product is

Product Name: MY8307
Product Name: Cherry Trail CR

in the modalias file for 808622C1 I found acpi:808622C1:808622C1:

and the only 2 things that had anything related to accelerometer were these

P: /devices/pci0000:00/808622C1:02/i2c-2/i2c-BOSC0200:00
E: DEVPATH=/devices/pci0000:00/808622C1:02/i2c-2/i2c-BOSC0200:00
E: DRIVER=bmc150_accel_i2c
E: ID_VENDOR_FROM_DATABASE=BOS
E: MODALIAS=acpi:BOSC0200:BOSC0200:
E: SUBSYSTEM=i2c
E: USEC_INITIALIZED=5496176

P: /devices/pci0000:00/808622C1:02/i2c-2/i2c-BOSC0200:00/iio:device0
N: iio:device0
E: DEVNAME=/dev/iio:device0
E: DEVPATH=/devices/pci0000:00/808622C1:02/i2c-2/i2c-BOSC0200:00/iio:device0
E: DEVTYPE=iio_device
E: IIO_SENSOR_PROXY_TYPE=iio-buffer-accel
E: MAJOR=247
E: MINOR=0
E: SUBSYSTEM=iio
E: SYSTEMD_WANTS=iio-sensor-proxy.service
E: TAGS=:systemd:
E: USEC_INITIALIZED=5755344

I also have no idea how to get the right ACCEL_MOUNT_MATRIX so I thought I'll go for trial end error... even tho I think that might be a bad idea.

sensor:modalias:acpi:BOSC0200*:dmi:*:svnCompletElectroServ*:pnMY8307:*
    ACCEL_MOUNT_MATRIX=-1, 0, 0; 0,1, 0; 0, 0,1

Edit: Solved

  • 3
    "I decided to give Kali a try " Why? – user8779 May 29 '18 at 18:15
  • 2
    that notebook chipset is already problematic by itself, do not make your life unnecessarily more complex running kali there. Try Fedora or Ubuntu. – Rui F Ribeiro May 29 '18 at 18:38
  • @RuiFRibeiro For some reason it won't run any other linux distro. I have tried Ubuntu, Parrot Sec, Linux Mint, BlackArch, Arch Linux, Anarchy. For Ubuntu, Mint and Arch and Anarchy the USB won't get detected for some reason. I also can't boot from the EFI Shell. (Even tho all of them work fine on my PC) As for Parrot, it installs fine but I won't boot properly, has a ton of glitches. Kali was the only one I could get running. I'll give Fedora a try. – Zero May 30 '18 at 14:43
  • Possible duplicate of Why is Kali Linux so hard to set up? Why won't people help me? – Jesse_b May 30 '18 at 16:01
  • @Zero when you say "the USB won't get detected" you mean in the BIOS, it won't see the USB flash drive containing the boot/install media? Because I have the same tablet and the same problem (trying to install Arch Linux). Do you have some guide/tutorial that you followed? Thanks! – VanLaser Sep 19 '18 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.