1

I'm trying to install a Fedora package, specifically the package poppler-utils versions 0.5x or later, but that currently only for Fedora. I don't have a lot of knowledge on Amazon Linux AMI, but from what I researched, they're mostly compatible with CentOS packages. BUT I'm not sure if installing Fedora packages are possible so I just want to make sure.

What I tried so far:

I tried to download the fedora package rpm, uploading to s3, and tried installing via the ebextension configs.

commands:
    command: yum -y localinstall https://s3.amazonaws.com/link_to_rpm.rpm

but that didn't work. I don't have the logs with me right now, but the logs said something like "poppler-utils 0.5x is an upgrade to poppler-utils 0.26.5". The erros was something along the lines of "required poppler-utils 0.5x".

Is there a way to install a Fedora package rpm? I am downloading the rpm's from here

Edit: Added logs

[Application update .../Command install_poppler-utils] : Activity execution failed, because: Loaded plugins: priorities, update-motd, upgrade-helper
  Examining .../poppler-utils-0.62.0-1.fc28.x86_64.rpm: poppler-utils-0.62.0-1.fc28.x86_64
  Marking .../poppler-utils-0.62.0-1.fc28.x86_64.rpm as an update to poppler-utils-0.26.5-17.17.amzn1.x86_64
  Resolving Dependencies
  --> Running transaction check
  ---> Package poppler-utils.x86_64 0:0.26.5-17.17.amzn1 will be updated
  ---> Package poppler-utils.x86_64 0:0.62.0-1.fc28 will be an update
  --> Processing Dependency: poppler(x86-64) = 0.62.0-1.fc28 for package: poppler-utils-0.62.0-1.fc28.x86_64
  --> Processing Dependency: libpoppler.so.73()(64bit) for package: poppler-utils-0.62.0-1.fc28.x86_64
  --> Finished Dependency Resolution
  Error: Package: poppler-utils-0.62.0-1.fc28.x86_64 (/poppler-utils-0.62.0-1.fc28.x86_64)
  Requires: poppler(x86-64) = 0.62.0-1.fc28
  Installed: poppler-0.26.5-17.17.amzn1.x86_64 (@amzn-main)
  poppler(x86-64) = 0.26.5-17.17.amzn1
  Error: Package: poppler-utils-0.62.0-1.fc28.x86_64 (/poppler-utils-0.62.0-1.fc28.x86_64)
  Requires: libpoppler.so.73()(64bit)
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest
  • The error seems fairly plain English for me...if you want to install this package, you need to get that another package named xxxx as well. Without you trying to installing both, and providing logs here, I do not see the point of this question. – Rui F Ribeiro May 29 '18 at 7:52
  • @RuiFRibeiro I added the logs. The logs says I require the package poppler(x86-64) = 0.62.0-1.fc28, but that's the exact version that I'm trying to install with the rpm. – JimmyW May 29 '18 at 14:10
2

You're trying to install just the poppler-utils subpackage. That requires a poppler package of the matching version. You'll need to install those both. This may work (it often does on RHEL7 based systems), but may end up being a rabbithole of dependency chasing, which even if successful will result in a frankenstein's monster of a system.

Why not just use Fedora Cloud Base (https://alt.fedoraproject.org/cloud/), which has the package version you need?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.