1

I am running Debian stable, on a Thinkpad T450 with 8GB of RAM. Hibernating the system works fine, the snapshot is saved. But when I resume, it shows the desktop from when I hibernated, e.g. log out selection menu with hibernate option stuck like it is being clicked/pm-hibernate command running. There is no mouse cursor and the system is not responsive in this time. After a while, LightDM starts. When I login, my applications are all gone. I am running Xfce as the desktop. I set the resume in /etc/default/grub and /etc/initramfs-tools/conf.d/resume. I have tried hibernating with the hibernate package, pm-hibernate, systemctl hibernate, Xfce session default, with the same result except that some show more verbose output saying that the snapshot is being saved/restoring system from snapshot. uswsusp is currently uninstalled.

I dual-boot Windows 10 and Debian. Hibernation is disabled in Windows 10. Before, I tried hibernating in Windows but it failed. Then I ran powercfg -h on to enable it, but did not test the hibernation. It is currently disabled by powercfg -h off.

codeo@codeo:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0   549M  0 part 
├─sda2   8:2    0 487.8G  0 part /mnt/windows
├─sda3   8:3    0 428.3G  0 part /
└─sda4   8:4    0  14.9G  0 part [SWAP]
codeo@codeo:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.4 (stretch)
Release:    9.4
Codename:   stretch
codeo@codeo:~$ uname -a
Linux codeo 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07) x86_64 GNU/Linux

Also, when resuming from hibernate the BIOS splash screen does not have some of the text it does when booting normally after shutdown. (I don't think this is related to the problem.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.