55

I use Alt+Space in Emacs, but in Xfce it pops up window manager menu at the upper left corner of a window. How do i disable Alt+Space for Xfce and change global keyboard shortcuts in general?

2 Answers 2

87

Here, in Xfce4 Settings Manager or launch xfce4-settings-manager from terminal,

In Window Manager configuration, find the keyboard part, look for Window operations menu, and then hit on Clear button, which will remove that shortcut key, effects immedately

enter image description here

1
  • 1
    It also allows to update other shortcuts, for example to move window to next/prev workspace. Very handy! Oct 8, 2015 at 6:55
18

Go to Menu → Settings → Settings Editor, select "xfce4-keyboard-shortcuts", select xfwm4 → custom → <Alt>Space, then press "Reset property" button. Every other key combination can be set and unset there too.

Settings Editor is the general way to configure everything in Xfce4, though not user friendly.

2
  • 1
    Indeed it is not user friendly. However, is there any user friendly way to configure shortkeys? Where I can just press the keys to configure them? Dec 3, 2017 at 13:55
  • There seem to be many keybindings that are not accessible via the Settings Manager, this is the only way I know to find them. I don't think either SM or SE are particularly user friendly, because you have to search around for the problematic keybinding. It would be nice if they had the ability to use the key combination and be brought to the setting to change.
    – Liam
    Jan 24 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.