0

I'm running Gnome (Wayland) on Arch Linux. I have configured the environment not to go to suspend, etc. when the lid is closed. When I close the lid, the monitor turns off for a second or two (as though it's responding to the laptop lid state changing), then turns back on. Likewise, when I open the lid, it turns off for a second or two, then turns back on. (If I wasn't careful, I might have thought the monitor was turning off when closing the lid...sneaky Gnome!)

How do I make it so that the computer stays on and responds to, e.g. network events, but the monitor doesn't stay on all day?

  • I don't use Gnome, but is something like xset dpms force off acceptable? – Sparhawk May 27 '18 at 6:31
  • Wayland? One of the commands here might work. – Sparhawk May 28 '18 at 12:53
  • From freedesktop: If your session manager handles ... the laptop lid switch on its own it is welcome to do so, but needs to disable logind's built-in handling of these events. So you might look for clues in the interaction of systemd-logind and gnome/wayland. – meuh May 28 '18 at 14:42
  • @Sparhawk Since I'm not running X, that doesn't work. – Limited Atonement May 29 '18 at 14:45
  • I'm not sure what happened to your comment, but was my link helpful? – Sparhawk May 29 '18 at 21:49
0

Use gdm. It handles this and many other things automatically.

  • 1
    Could you elaborate on that a bit? Maybe tell us where to set the options needed? – Mioriin May 31 '18 at 2:19
  • @Mioriin I didn't have to set up anything. sudo pacman -Syu gdm; sudo systemctl enable gdm; sudo reboot; That's it. That's why my answer has the word "automatically" :-) – Limited Atonement Jun 1 '18 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.