4

Apparently I broke my Debian system again.

If I want to install anything using apt I get the following warning:

Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (< 2.25) but 2.27-3 is to be installed
 locales : Depends: libc-bin (> 2.27) but 2.24-11+deb9u3 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Following this hint is no use, as it only results in

The following packages were automatically installed and are no longer required:
  bc cups-browsed cups-core-drivers cups-daemon cups-filters cups-filters-core-drivers
  cups-ppdc cups-server-common dc foomatic-db-compressed-ppds foomatic-db-engine hp-ppd
  hplip-data libart-2.0-2 libavahi-glib1 libcupscgi1 libcupsmime1 libcupsppdc1
  libfontembed1 libgutenprint2 libhpmud0 liblouisutdml-bin liblouisutdml-data
  liblouisutdml7 libqpdf17 libsane-hpaio libsnmp-base libsnmp30 mscompress
  openprinting-ppds printer-driver-all printer-driver-brlaser printer-driver-c2050
  printer-driver-c2esp printer-driver-cjet printer-driver-dymo printer-driver-escpr
  printer-driver-foo2zjs printer-driver-foo2zjs-common printer-driver-fujixerox
  printer-driver-hpijs printer-driver-m2300w printer-driver-min12xxw
  printer-driver-pnm2ppa printer-driver-ptouch printer-driver-pxljr
  printer-driver-sag-gdi python3-pexpect python3-pil python3-ptyprocess
  python3-renderpm python3-reportlab python3-reportlab-accel qpdf ssl-cert
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  cups hplip libc-bin locales printer-driver-gutenprint printer-driver-hpcups
  printer-driver-postscript-hp printer-driver-splix task-english task-print-server
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  libc-bin
0 upgraded, 0 newly installed, 10 to remove and 7 not upgraded.
1 not fully installed or removed.
After this operation, 22.0 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] 

A quick Google search informed me that removing libc-bin is a terrible idea, which and idiot like me should never do. The question is now, how can I fix my problem?


Further info:

$ cat /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main
# deb cdrom:[Debian GNU/Linux 9.4.0 _Stretch_ - Official amd64 NETINST 20180310-11:21]/ stretch main
deb http://ftp.de.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.de.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.de.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ stretch-updates main contrib non-free

Requested by comments:

$ sudo apt install libc-bin/stable

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc-bin is already the newest version (2.24-11+deb9u3).
Selected version '2.24-11+deb9u3' (Debian:9.4/stable [amd64]) for 'libc-bin'
Selected version '2.24-11+deb9u3' (Debian:9.4/stable [amd64]) for 'libc6' because of 'libc-bin'
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (< 2.25) but 2.27-3 is to be installed
 locales : Depends: libc-bin (> 2.27) but 2.24-11+deb9u3 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

$ cat /etc/apt/sources.list.d/*

# deb-src http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu cosmic main
# deb-src http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu cosmic main

$ apt-cache policy

Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.de.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin ftp.de.debian.org
 500 http://security.debian.org/debian-security stretch/updates/non-free amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/contrib amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.de.debian.org/debian stretch/contrib amd64 Packages
     release v=9.4,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=amd64
     origin ftp.de.debian.org
 500 http://ftp.de.debian.org/debian stretch/non-free amd64 Packages
     release v=9.4,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=amd64
     origin ftp.de.debian.org
 500 http://ftp.de.debian.org/debian stretch/main amd64 Packages
     release v=9.4,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin ftp.de.debian.org
Pinned packages:

$dpkg --list libc6

 Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name             Version       Architecture  Description
+++-================-=============-=============-=====================================
ii  libc6:amd64      2.27-3        amd64         GNU C Library: Shared libraries

find /lib -name libc-\*

/lib/x86_64-linux-gnu/libc-2.27.so
4
  • What is the output of apt-cache policy?
    – GAD3R
    Commented May 27, 2018 at 11:09
  • I suspect you have an odd version of libc installed, what is the output of the following commands: dpkg --list libc6 and find /lib -name libc-\*. Commented May 27, 2018 at 23:05
  • 1
    @GAD3R I already tried apt --reinstall install libc-bin, but this prompts just the error of unmet dependencies that I pointed out already.
    – DerWeh
    Commented May 28, 2018 at 14:33
  • 1
    I had same problem. Fixed by downloading libc-bin deb file manually from Debian repo and installing it with dpkg -i, then running apt --fix-broken install
    – Pyroman
    Commented Aug 4, 2019 at 0:20

1 Answer 1

0

The problem seems to be that you've somehow installed (or at least convinced dpkg that it's available) a newer version of the locales package. The one available in Stretch only depends on libc-bin (>> 2.24), while your output shows that your apt sees a version depending on libc-bin (> 2.27) (you might say it's inconsistent that dpkg uses >> in dependencies and apt outputs > in cases like this, that's the way it is, they mean the same).

The locales package is not essential, so I would try to remove that and then install it again afterwards, if you have a lot of locales compiled that might take a while.

3
  • 2
    Thanks for the help, but it seams that removing locales doesn't change anything. Removing it results in libc-bin : Depends: libc6 (< 2.25) but 2.27-3 is to be installed task-english : Depends: locales but it is not going to be installed
    – DerWeh
    Commented May 27, 2018 at 3:45
  • I won't rule out that your system can be saved, but it's not going to be easy and it needs more information and more interaction than really fits SE (maybe the chat works). Commented May 27, 2018 at 11:26
  • Thanks for the help, I am willing to provide any information I can. I just have no knowledge of Linux and currently waiting in an airport with 1KiB/s connection.
    – DerWeh
    Commented May 27, 2018 at 16:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .