0

I'm uploading a file through rsync and I found my upload speed is 10 times slower than what my ISP allows:

rsync -a --info=progress2 --human-readable --rsh="sshpass -p pass ssh -l me8" folder username@host:~/public_html/

I tried adding the -c arcfour option to decrease the level of encryption, with no luck:

rsync -a --info=progress2 --human-readable --rsh="sshpass -p pass ssh -c arcfour -l me8" folder username@host:~/public_html/

I also tried using ncftp as I don't really need the encryption, but I'm still getting the same limit:

ncftpput -u username -p pass -R host /public_html/ ./folder/

Now if I upload files through my browser, or if I test my connection on a "speed test" website, I get the full upload speed my ISP allows.

Note that I'm running Ubuntu 16.04 on a virtual machine, with the host machine being a Windows machine, and that I've found the same problem on this Windows machine: upload speed is limited in Filezilla but not in the browser.

I don't know what to check at the moment, any idea?

  • 1
    Your 10x sounds like it could be a confusion between Mb/s and MB/s. What speed do you get and what do you expect? – roaima May 26 '18 at 11:23
  • haha I've been searching for so long and I didn't notice it's a kb/s in one case and kB/s in the other. Good catch! Should you post a separate answer? – Sulli May 26 '18 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.