Yesterday, I had Archlinux on my Dell Latitude E6520 and the sound was working perfectly fine (I even had the loud beep I couldn't get rid of).

Today, I installed Debian and alsa. The first surprise was that in alsamixer, I had half as many playback devices shown... I unmuted them and it somehow worked - at least when I had my headphones plugged in. But after trying to make the sound work on Heroes of Newerth, I tried on Chromium (a game I had installed thinking it was the browser T.T) and it didn't have sound either... Now the odd part is that I'm listening to music on Google chrome while writing this message...

The output of this first command looks to me like the one I had on Archlinux:

lspci -v |grep Audio
00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 04)
01:00.1 Audio device: nVidia Corporation Device 0e08 (rev a1)

But when I use alsamixer and press F6 (Select sound card), I only have 3 choices:

- (default)
0 HDA Intel PCH
  enter device name...

Whereas I'm quite sure I had a fourth one under Archlinux.

I tried to install this http://www.dell.com/support/drivers/us/en/19/Product/latitude-e6520?s=dhs But apparently it doesn't work... Not that I expected it to work, it's intended for Ubuntu...

sudo dpkg -i alsa-driver-hda-krug-ubuntu-audio-dev-dkms_2.
(Reading database ... 129240 files and directories currently installed.)
Preparing to replace alsa-driver-hda-krug-ubuntu-audio-dev-dkms (using alsa-driver-hda-krug-ubuntu-audio-dev-dkms_2. ...

Deleting module version:
completely from the DKMS tree.
Unpacking replacement alsa-driver-hda-krug-ubuntu-audio-dev-dkms ...
Setting up alsa-driver-hda-krug-ubuntu-audio-dev-dkms ( ...
Loading new alsa-driver-hda-krug-ubuntu-audio-dev- DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-5-amd64
Building for architecture amd64
Building initial module for 2.6.32-5-amd64

Error! Bad return status for module build on kernel: 2.6.32-5-amd64 (amd64)
Consult the make.log in the build directory
/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/ for more information.

Here is the content of the make.log:

/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/$ ls
dkms.conf    hda_codec.o    hda_hwdep.c  idt90.patch  patch_analog.c  patch_cirrus.o    patch_hdmi.c     patch_si3054.o
hda_beep.c   hda_eld.c      hda_intel.c  Kbuild       patch_analog.o  patch_cmedia.c    patch_hdmi.o     patch_sigmatel.c
hda_beep.h   hda_eld.o      hda_local.h  Kconfig      patch_ca0110.c  patch_cmedia.o    patch_realtek.c  patch_sigmatel.o
hda_codec.c  hda_generic.c  hda_proc.c   Makefile     patch_ca0110.o  patch_conexant.c  patch_realtek.o  patch_via.c
hda_codec.h  hda_generic.o  hda_proc.o   make.log     patch_cirrus.c  patch_conexant.o  patch_si3054.c   patch_via.o
xavierm02@xavierm02-D-L:/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/$ cat make.log
DKMS make.log for alsa-driver-hda-krug-ubuntu-audio-dev- for kernel 2.6.32-5-amd64 (amd64)
Thu Aug  2 17:17:56 EDT 2012
make -C /lib/modules/2.6.32-5-amd64/build M=/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/ modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.32-5-amd64'
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
  CC [M]  /var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/
/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/ In function ‘parse_hints’:
/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/ error: implicit declaration of function ‘skip_spaces’
/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/ warning: assignment makes pointer from integer without a cast
/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/ warning: assignment makes pointer from integer without a cast
make[4]: *** [/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/] Error 1
make[3]: *** [_module_/var/lib/dkms/alsa-driver-hda-krug-ubuntu-audio-dev/] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-5-amd64'
make: *** [all] Error 2

I don't think the driver on the dell website is the way to go since I didn't use it to get everything working on Archlinux but I'm not sure at all.

Another thing I think I did on Archlinux is install a package with a really long name that (maybe) had something to do with audio and had me use uname -r to know which one intall. I went through my whole history and couldn't find where I found out I had to install this... Neither could I recall the name of the package... But I'm quite sure it had something to do with alsa... (because the only other thing it could've been is something about nvidia and I installed nvidia with a downloaded tar.gz...)

By the way, uname -r returns 2.6.32-5-amd64.

I have pulseaudio installed.

PS: Sound only works with headphones at the moment, but that's not the biggest issue.

PS 2: Sound works in Mumble if I set the output to ALSA. Setting the sound to ALSA in HoN won't change anything. And Chromium doesn't give you any kind of choice.

In case it somehow matters, HoN is launched in another instance of the X server on :1 whereas the rest remains on :0.

closed as off-topic by Braiam, Anthon, Ramesh, Faheem Mitha, jasonwryan Sep 20 '14 at 20:34

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Braiam, Anthon, Ramesh, Faheem Mitha, jasonwryan
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Shame on me... I wasn't in the audio group -.- That fixes the problem about not having sound in all applications. But I still never get sound on the speakers of the laptop. – xavierm02 Aug 4 '12 at 16:52

The likely answer as to why you're not getting sound from the speakers is that you've got a mute turned on, or volume control at zero in alsamixer. On the Intel HDA device I've got access to, this means setting 'Speaker' to 'OO' rather than 'MM'. Remember that the alsamixer interface can scroll (marked with a series of arrows on the left and right)!

The nVidia device is, most likely, for audio over HDMI/DVI/DisplayPort, so it won't be affecting your current audio problems.

The reason that you're not seeing your nVidia device in the alsamixer selection, but you can see it in the output of lspci is, almost certainly, because you don't have the appropriate drivers loaded. lspci just shows what you've got plugged in, regardless of whether there are drivers for it, whereas alsamixer shows the devices that are usable as sound cards - hence they must have drivers loaded.

Should you want audio over the digital video port, I believe you need to install the closed source nVidia drivers (which are available in Debian non-free) - at present you're probably using the open source nouveau drivers. The Debian documentation at https://wiki.debian.org/NvidiaGraphicsDrivers should tell you how to do this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.