I would like to try FreeBSD so installed 11.1 64bit on a VirtualBox VM.

Out of the box there is no internet connection so as suggested here I did ifconfig and

dhclient em0:

dhclient already running, pid: xxx.

exiting

ping freebsd.org

ping: cannot resolve freebsd.org: Host name lookup failure

ping 8.8.8.8

64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=xx.xxx ms

What am I missing? Average linux LiveCD works just fine.

up vote 3 down vote accepted

Out of the box there is no internet connection

This is patently not true, given that you demonstrate packets going to and from 8.8.8.8.

What am I missing?

You probably forgot to start your proxy DNS server. You have a choice of several in Ports/Packages. The Handbook recommends running unbound, with

local_unbound_enable=yes
in /etc/rc.conf. It's that simple. The default resolv.conf already points DNS client libraries at it.

I use an improved version of Bernstein's dnscache myself.

Further reading

  • Many thanks! This is patently not true, given that you demonstrate packets going to and from 8.8.8.8. - At first I didn't realize it's just dns that's missing, edited in ping 8.8.8.8 part later. – alm Jun 2 at 17:18

Found the answer here,

Had to edit /etc/resolv.conf and replace nameserver parameter value 127.0.0.1 with a network dns server.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.