3

Running GIMP on my KDE desktop the tooltips are all white-on-white. How do I fix this?

2

To quote this answer by Narcolessico to the generalisation of this question on Super User, i.e. https://superuser.com/questions/1100408/tooltips-of-gtk-applications-are-unreadable-within-kde:

The issue is due to a partial override of GTK colors by means of KDE style.

Open System Settings > Colors, deselect Apply colors to non-Qt applications, restart the GTK application (e.g. Gimp). This breaks the feeling that all applications share the same style but tooltips will be again readable in both Qt and GTK applications.

This solution leaves the rest of Gimp looking much the same, while Matthew Cline’s answer here (use high contrast Gtk themes) makes Gimp look (in my eyes) pretty clunky.

Anyone wanting fine-grained control should probably use https://superuser.com/a/1190633/571648, which tells you which configuration files to edit, though their location seems to be different on my installation.

  • It is Apply colours to non-KDE4 applications in my case (KDE4.14 on CentOS 7.7). – scrutari Feb 18 at 22:02
1

Go to KDE system settings, then pick Application Style, then pick GNOME Application Style (GTK). For both Select a GTK2 Theme and Select a GTK3 Theme choose HighContrast, then click on Apply.

  • Many thanks; it makes the tootips readable but is pretty ugly. I might look into defining it oneself, but for now perhaps I shall just live with it. – PJTraill Dec 16 '18 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.