2

I have recently acquired a Hades Canyon (Intel Nuc8i7hvk) and I'm trying to put Linux on it.

I have tried Ubuntu 18.04/Debian 9.4. On the Ubuntu 18.04 version I make it to the GRUB options page, and then I see a black screen hanging on the system.

On Debian 9.4 I make it to the GRUB options page with the initial screen, and then I see a black screen hanging on the system once I select any option.

In both cases I have set the nomodeset option, but I haven't been successful.

I have not yet succeeded with the following options:
  Bios 037 - nomodeset (in the GRUB entry options)
  Bios 040 - nomodeset (in the GRUB entry options)

Has anyone been successful in installing Linux on this machine? I was thinking about lack of GPU drivers bundled in the distro. Would it be possible to "attach" those AMDGPU drivers in the distro?

I've read elsewhere that I need at least 4.15 Linux kernel which should be available on the Ubuntu 18.04 release.

0

I am no Linux expert. I have however, been able to get Ubuntu, Linux Mint, and Debian, opensuse, and elementaryos all to work, with just a portion of what you described. All i changed was, adding the nomodeset, to the grub options. Once installed, I then had to go back in, using the terminal, and add it to grub again. This was needed, in order to force the nomodeset across restarts. The portion that does not work for me, is the multi-monitor configuration. I am not sure on the specific versions, as I attempted many different distros, just trying to get it to work. I have read that we would need to wait until the 4.18 kernel is available, before this will be supported. For the time being, I have switched back to the skull canyon.

  • Thanks, I installed a Windows ISO to confirm that nothing is seriously wrong with hardware, and thankfully it installed successfully. May I ask which particular Debian ISO image did you try ? – davide May 26 '18 at 15:28
  • I did the Windows install to test as well. That is when I researched and found out that the hardware will require the 4.18 kernel. The image I used for Debian was the debian-live-9.4.0-amd64-cinnamon. This too was similar to the others, in that the grub boot loader needed just the nomodeset option added to the end of the linux boot line. – BobP May 26 '18 at 18:13
  • Tried again, and I got the infamous black screen. On one attempt I managed to enter into console mode and sniffed the error. 'Failed to start Detect the available GPUs and deal with any system changes, followed by Failed to start Light Display Manager' I managed to install Fedora 28 successfully without any issues, so I will be sticking to that until a Debian distribution is available. The Fedora 28 I got has Kernel 4.16.3-301.fc28.x86_64 It also saw the Vega Card, 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Polaris 22 [Radeon RX Vega M GL] (rev c0) – davide May 27 '18 at 10:20
0

Until the kernel catches up, Fedora KDE (https://spins.fedoraproject.org/en/kde/) works by installing in trouble shooting mode. Also Solus OS (https://solus-project.com/) installed and ran without modification -- until I did the updates and rebooted. Then it came up as a terminal.

  • Tried both, Fedora KDE worked out of the box in rescue mode! Thanks. Kernel 4.16.3-301.fc28.x86_64 I wasn't successful with Solus OS. – davide May 27 '18 at 10:21
0

After re-flashing BIOS to the latest version I have successfully installed XUbuntu without modifying any settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.