1

I wrote an app in Qt using the QtWebEngine component to display a simple Web page with SVG elements on a 7" LVDS screen. The app is running on a UDOO Neo board and over a custom Linux installation built with OpenEmbeded with this meta-udoo layer: https://github.com/cyrilfr/meta-udoo with meta-freescale and meta-qt5.

After a while, I've seen the screen starting to freeze and the QWebEngineProcess crashing randomly. The CPU usage of the QWebEngineProcess is about 40% and the temperature goes up to 55°C and over 65°C when the UDOO Neo is put in a box!

When the screen starts to freeze, I get a kernel message: GPU too hot!

Here is the output of the ps -aux command:

root       456  0.0  1.8  92624 18792 ?        S    May24   0:00 /usr/lib/qt5/libexec/QtWebEngineProcess --type=zygote --lang=C
root       476 39.1 10.1 291900 104396 ?       Sl   May24 355:07 /usr/lib/qt5/libexec/QtWebEngineProcess --type=renderer --disable-accelerated-video-decode --enable-overlay-scrollbar --enable-pinch --enable-threaded-compositing --enable-viewport --main-frame-resizes-are-orientation-changes --profiler-timing=0 --use-gl=egl --disable-composited-antialiasing --lang=C --enable-pinch --num-raster-threads=1 --content-image-texture-target=3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553,3553 --video-image-texture-target=3553 --channel=431.2.942434774

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.