3

I've been trying to use a SOCKS Proxy which I have been using with success from an Ubuntu 11.4 box with GNOME on my Debian box with KDE.The socks server is bound to the local port 1080 through the following ssh command:

ssh -p222 -D 1080 <my_username>@socks_server_domain_name

Following the advice I found here: http://emilsedgh.info/blog/index.php?/archives/14-SOCKS-proxy-on-KDE.html I edited my ~/.kde/share/config/kioslaverc file and now it looks like this:

jason@debian-laptop:~$ cat ~/.kde/share/config/kioslaverc
PersistentProxyConnection=true

[$Version]
socksProxy=socks://localhost:1080
update_info=kioslave.upd:kde2.2/r1,kioslave.upd:kde2.2/r2,kioslave.upd:kde2.2/r3

However, once I use System Settings->Network Settings->Proxy, I click on "Manually specify the proxy settings", but the dialog won't let me hit "apply" without prompting me to fill in information in the "setup" dialog:

screenshot

which is not helpful at all, because there is no "SOCKS" protocol option in the "setup" dialog.

I'd also like to add that, when switching to GNOME in the same box, I am able to run the SOCKS proxy by specifying "localhost" and "1080" in System->Preferences->Network Proxy, in exact the same way I did it in my Ubuntu box.

  • 1
    From the blog you link to: "kdelibs < 4.7: its not supported. to make it work, you have to install an http server (like polipo) and point kde to it." KDE 4.4.x uses kdelibs ~4.4. Did you try to get polipo running? – Mat Aug 2 '12 at 18:53
  • Apologies for the belated comment, yet I have been ridiculously busy. I installed polipo, edited the polipo configuration file and have the following lines uncommented: socksParentProxy = "localhost:1080" socksProxyType = socks5 Afterwards I bind the SOCKS proxy to the local 0 port 1080 via the aforementioned ssh snippet yet I still have no luck; the Internet connection of my browser is not routed through the proxy. – Jason Aug 22 '12 at 3:51
0

I came across the same problem trying to set Amarok to use proxy. I compiled hints from several different places into my kioslaverc config file, which looks like this now:

... ~$ cat $HOME/.kde/share/config/kioslaverc
[$Version]
update_info=kioslave.upd:kde2.2/r1,kioslave.upd:kde2.2/r2,kioslave.upd:kde2.2/r3

[Proxy Settings][$i]
ProxyType=1
NoProxyFor=127.0.0.1,localhost
PersistentProxyConnection=true
socksProxy=socks://localhost:1080

Now proxy settings for Amarok (and I think generally for KDE applications as well) are applied and connection goes routed properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.