1

I’m trying to install Timeshift (.deb file) on Raspbian 9.4 and I used

sudo apt install ./fileName.deb

which produced

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'timeshift:i386' instead of './timeshift-v18.4-i386.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 timeshift:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
              Depends: libcairo2:i386 (>= 1.2.4) but it is not installable
              Depends: libgdk-pixbuf2.0-0:i386 (>= 2.22.0) but it is not installable
              Depends: libgee-0.8-2:i386 (>= 0.8.3) but it is not installable
              Depends: libglib2.0-0:i386 (>= 2.35.9) but it is not installable
              Depends: libgtk-3-0:i386 (>= 3.16.2) but it is not installable
              Depends: libjson-glib-1.0-0:i386 (>= 0.13.2) but it is not installable
              Depends: libvte-2.91-0:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

The Timeshift website says that “you may need to install packages for the following dependencies libgee json-glib rsync”. I assume those are separate packages that I will need to install first but how would I do that? The same way I attempted to install the .deb file? Thanks so much in advance.

2
  • @StephenKitt I added the output but essentially I am just wondering how to install this application and if I need to install those packages, how I would do that. – jt.j May 25 '18 at 4:48
  • The reason I asked for the output is that apt install takes care of dependencies; so if it fails to install something, it means there’s an issue somewhere, and we need the output to determine what that could be. – Stephen Kitt May 25 '18 at 5:27
3

I’m guessing you downloaded the package from the Timeshift releases page. That only provides binary releases for amd64 and i386, neither of which can be used on your Raspberry Pi (which is armhf).

You’ll need to build Timeshift from source; Raspbian 9.4 has all the necessary build dependencies. You can use the enclosed build-deb.sh script, after editing it to change xenial to stretch:

git clone https://github.com/teejee2008/timeshift.git
cd timeshift
sed -i s/xenial/stretch/g build-deb.sh
./build-deb.sh armhf

This will tell you what programs to install.

5
  • I downloaded the amd64 version and tried to install it, but I got the same output. I – jt.j May 25 '18 at 15:46
  • 9.4. It is raspbian if that affects it at all – jt.j May 25 '18 at 16:03
  • Yes I’m sorry I should have mentioned that earlier – jt.j May 25 '18 at 16:05
  • Where is the build-deb.sh script? – jt.j May 25 '18 at 16:32
  • In the Timeshift source code, see my update. – Stephen Kitt May 25 '18 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.