0

So I have compton, a composite manager that I use to make things look prettier, mostly to add shadows to windows, and make things transparent.

I also have ffcast, which I currently am using to make gifs or mp4s by selecting a part of my screen and recording it.

The two don't seem to mix well however, as if I start recording with compton being enabled...

Whoops

This happens! The entire region is covered by a shadow! I'm sure this is caused by compton, but I have some problems. Firstly, I'm not too sure how the shadow-exclude option works in compton, apart that if you add something like:

shadow-exclude = ["class_g = 'something'"];

...it will avoid displaying shadows on all applications which have the WM_CLASS 'something'.

I can find the WM_CLASS of any window using xprop WM_CLASS however which should make things easier, however, this does not work with the shadowy region as it just selects whatever it is covering.

So I am at a loss. I'm not sure whether this is a bug that's possible to fix or what, but I cannot find a way to remove this shadow apart from turning off compton completely or removing shadows entirely, which I do not want to do. Is there a special option for shadow-exclude that I am missing, or something else that I could do, or is this impossible to fix?

Thank you very much in advance.

PS. Here's my compton.conf file before I forget:

shadow-radius=10;
shadow-opacity=0.9;
shadow-offset-x=-15;
shadow-offset-y=-15;
shadow = true;
no-dock-shadow = false;
no-dnd-shadow = true;
clear-shadow = true;
inactive-dim = 0.25;
inactive-opacity = 0.9;
fading = true;
fade-delta = 5;
opacity-rule = [ "99:class_g = 'URxvt'" ];
shadow-exclude = [
    "class_g = 'Firefox' && argb",
    "name = 'ffmpeg'"
];

#Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = false; };
  menu = { shadow = false; };
  dropdown_menu = { shadow = false; };
  popup_menu =  { shadow = false; };
  utility =  { shadow = false; };
};
0

Adding "window_type *= 'normal' && ! name ~= ''" to the list of shadow-exclude fixed the problem right up! I'm pretty sure this is because the area has no WM_CLASS, and as such is now excluded from having a shadow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.