0

DISTRIB_ID=ManjaroLinux

DISTRIB_RELEASE=17.1.6

DISTRIB_CODENAME=Hakoila

I installed manjaro on an old laptop today and am in the process of trying to update it.

just using pacman -Syyu eventually gave me

(383/383) checking keys in keyring
downloading required keys...
:: Import PGP Key KEY, "Brad Fanella <cesura@archlinux.org>", 
created: 2018-03-2? [Y/n] Y
error: key "Brad Fanella <cesura@archlinux.org>" could not be imported
error: required key missing from keyring
error: failed to commit transaction (unexpected error)

I tried this sequence, to no avail:

sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Syy
sudo pacman -S manjaro-keyring archlinux-keyring
sudo pacman -Syyu

Any ideas?

EDIT 1

Tried pacman-key --recv-keys F382BBBD and got this:

gpg: key 81A402D4F382BBBD was created 6 days in the future (time warp or clock problem)
gpg: key 81A402D4F382BBBD: no valid user IDs
gpg: this may be caused by a missing self-signature
gpg: Total number processed: 1
gpg:           w/o user IDs: 1
1

Solved.

From EDIT 1 output,

I updated the clock using sudo ntpdate -vu time.nist.gov

then pacman-key --recv-keys F382BBBD and voilà.

That was annoyingly simple.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.