0

I can't resume from hibernate on my Lubuntu 16.04 on a Dell Latitude 5480 notebook. The system boots but a blank screen is displayed instead of the login page. The swap partition is twice the RAM size.

What can I do to debug it?

PS: previously I can't even start it, I had to resize the swap partition.

0

To test if hibernate works in your computer, open terminal (Ctrl+Alt+T) and run command:

sudo pm-hibernate

After your computer turns off, switch it back on. Did your open applications re-open? If hibernate does not work, check if your swap partition is at least as large as your available RAM.

Enable Hibernate Option:

If hibernate works, you can continue using the above command to hibernate your machine, or enable the option in shutdown menu by editing the configuration file.

To do so, open terminal (Ctrl+Alt+T) and run command:

gksudo gedit /var/lib/polkit-1/localauthority/10- 

vendor.d/com.ubuntu.desktop.pkla

When the files opens after running the command, scroll-down and file out both section:

  • [Disable hibernate by default in upower]
  • and [Disable hibernate by default in logind]

Change their values from no to yes:

Save the file and reboot.

In addition, for some devices above changes may not work. A workaround is to use below command instead:

gksudo gedit /etc/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

And when the file opens, paste below content and save the file.

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.