root@abacus-desktop:~# apt-get install openssh-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  openssh-server: Depends: openssh-client (= 1:5.3p1-3ubuntu7) but 1:5.3p1-3ubuntu3 is to be installed
  wireshark: Depends: libsmi2ldbl but it is not going to be installed
  wireshark-common: Depends: libsmi2ldbl but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
  • Tried aptitude? It seems to be a little cleverer, it will probably offer you some alternatives fixing the issue. (Run aptitude, search (with the / key) for openssh-server), press +, ...) – sr_ Aug 2 '12 at 7:16
  • I did like you said, and there is #Broken: 2 – cindy Aug 2 '12 at 7:27
  • Doesn't it suggest a fix? (Have a look here on how this could work, analogously.) – sr_ Aug 2 '12 at 7:36
  • OK thanks all. It works now! I removed the packages wireshark, wireshark-common and another package interfering with libsmi21db1. Re-installed everything, not it works fine. Thanks! – cindy Aug 2 '12 at 8:39

Your problem description is really vague.

Did you try to run apt-get -f install as suggested to fix the broken dependencies? Did you mix different versions in your sources.list?

  • Sorry, I am a newb to ubuntu. What is sources.list? – cindy Aug 2 '12 at 7:27
  • The file /etc/apt/sources.list where the repositories of your package manager are configured. – scai Aug 2 '12 at 7:30
  • With apt-get install -f: <br/><br/> Unpacking libsmi2ldbl (from .../libsmi2ldbl_0.4.8+dfsg2-2_i386.deb) ... dpkg: error processing /var/cache/apt/archives/libsmi2ldbl_0.4.8+dfsg2-2_i386.deb (--unpack): trying to overwrite '/usr/bin/smicache', which is also in package libsmi 0:0.4. 5-4 dpkg-deb: subprocess paste killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/libsmi2ldbl_0.4.8+dfsg2-2_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – cindy Aug 2 '12 at 7:45
  • There seems to be a broken package, either libsmi2ldbl or libsmi. Both provide /usr/bin/smicache and thus conflict with each other. Try removing one of those two packages. – scai Aug 2 '12 at 7:47
  • What command to use to remove the package? sorry...i just started using linux 1 week ago. is it apt-get remove package – cindy Aug 2 '12 at 8:03

I had a very similar problem with 13.04 (but it was instead complaining that the openssh-client to be installed is NEWER than the one required).

Turns out that the software sources was configured to download from a servers local to the country where I'm residing (Kuwait).

I solved it by opening Ubuntu Software Center application, then going to the "Edit > Software Sources", then in the Ubuntu Software tab I change the Donwload from drop down list to "Main Server".

I then ran sudo apt-get update followed by sudo apt-get upgrade and finally sudo apt-get install openssh-server and this time it installed without a hitch.


It seems your repository dependencies are broken. Try to clean your /etc/apt/sources.list. Which is a text file that has all your repositories of packages. Probably you have edited it.

Then do an apt-get update. You should tell us your Ubuntu version, and why seems you have another dependencies broken like Wireshark.

  • I am using Ubuntu 10.04 LTS and when I try to install Wireshark, it says apt-get: /home/thot/SC/ST/bin/libstdc++.so.6: version GLIBCXX_3.4.9' not found (required by apt-get) apt-get: /home/thot/SC/ST/bin/libstdc++.so.6: version GLIBCXX_3.4.11' not found (required by apt-get) apt-get: /home/thot/SC/ST/bin/libstdc++.so.6: version GLIBCXX_3.4.11' not found (required by /usr/lib/libapt-pkg-libc6.10-6.so.4.8) apt-get: /home/thot/SC/ST/bin/libstdc++.so.6: version GLIBCXX_3.4.9' not found (required by /usr/lib/libapt-pkg-libc6.10-6.so.4.8) – cindy Aug 2 '12 at 7:36
  • Here is my souces.list deb archive.ubuntu.com/ubuntu lucid-security main restricted deb-src archive.ubuntu.com/ubuntu lucid-security main restricted deb archive.ubuntu.com/ubuntu lucid-security universe deb-src archive.ubuntu.com/ubuntu lucid-security universe deb archive.ubuntu.com/ubuntu lucid-security multiverse deb-src archive.ubuntu.com/ubuntu lucid-security multiverse – cindy Aug 2 '12 at 7:39
  • it seems you have an strange configuration of your distro installation. something is wrong. it seems you have your library path placed wrong. it is a fresh installation? – logoff Aug 2 '12 at 7:48
  • yes it is a fresh installation – cindy Aug 2 '12 at 8:05
  • Try a fresh installation of Ubuntu 12.04 "Precise" instead. It's 2 years newer and is the latest Long Term Service release, from April this year. Also unless you intend to regularly rebuild source packages, comment out the deb-src lines in your /etc/apt/sources.list - save time downloading and parsing them every time you run apt-get update – cas Aug 2 '12 at 8:38

Your missing packages are probably in repositories that are commented out in your sources.list (i.e. they are not enabled). Update your repositories first, then try to install again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.