0

My CentOS 7.5 VM pops up a blank screen after that is left unused for some time (~15 minutes). When the mouse is moved, it shows a clock in the middle of the screen and requests a password to unlock. This although all settings say otherwise:

Settings -> Power -> Power Saving -> Blank screen: Never
Settings -> Power -> Power Saving -> Suspend -> Automatic suspend: Off
Settings -> Privacy -> Screen Lock: Off

Is there any other setting to change?

GNOME version is 3.25.4.

  • It's the Screensaver. In Gnome 2 it is (Menu) > System > Preferences > Look and Feel >> Screensaver : "Lock screen when screensaver is active". ... Gnome 3 : I guess the settings can be found in the Control center. – Knud Larsen May 22 '18 at 18:41
0

It appears I've incorrectly diagnosed the problem. Inactivity, as per the current settings, does not trigger the lock screen.

Pressing Win + L, while in the CentOS guest, locks the screen in the CentOS guest and also in the Win10 host. It looks like VMware forwards the key combination to the host OS. So the most likely explanation is that I must have locked the screen while in the guest OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.