1

I've just installed Debian 9 without desktop environment into an old notebook and, apparently, the command line is working just fine.

However, the system always starts with some random combination (usually one to five messages) of the following types of errors:

Debian GNU/Linux 9 debian tty1
debian login:
[drm: intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[drm: intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* pipe A underrun
[drm: intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=3 end=3055553384) time 9 us, min 476, max 479, scanline start 3, end 479

Although this errors doesn't seem to be affecting the system, I'd rather be more cautious (in rare occasions the system doesn't boot and stays in a black screen). Fixing this now can prevent future headaches.

Any ideas?


Notes

Adding i915.modeset=0 to the boot parameters apparently avoids the error messages. However, this option disables the framebuffer causing a low resolution console (kernel mode-setting). Most likely this is not a fix to the problem, since it is only disabling what should be working in the first place.


Notebook Specifications
Toshiba Satellite 1135-S1553

  • Intel® Celeron® 4 processor at 2.20GHz
  • Intel 852GM Chipset
  • 1Gb RAM
  • 32MB internal Integrated Intel® 852GM video memory

Debian Version

Software selection
(  ) Debian desktop environment
(  ) ... GNOME
(  ) ... Xfce
(  ) ... KDE
(  ) ... Cinnamon
(  ) ... MATE
(  ) ... LXDE
(  ) web server
(  ) print server
(  ) SSH server
(X) standard system utilities

outputs and log files excerpts
/var/log/installer# grep EE Xorg.0.log

(WW) warning, (EE) error, (NI) not implemented, (??) unknown
[8.534] (EE) Failed to load module "intel" (module does not exist, 0)
[8.535] (EE) Failed to load module "vesa" (module does not exist, 0)
[8.538] (EE) open /dev/dri/card 0: No such file or directory
[8.538] (EE) open /dev/dri/card 0: No such file or directory
[8.538] (EE) Screen 0 deleted because of no matching config section

dmesg | grep -i error

[ 7.968213] EXT4-fs (sda1): re-mounted. Opts: errors - remount-ro
[12.487005] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[12.487086] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* pipe B underrun
[12.487164] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
[22.989944] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* pipe A underrun

dmesg | grep -i firmware

[ 0.115078] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[11.166138] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
  • Seems to be a kernel bug related to your Intel GPU. Could you try passing i915.enable_rc6=0 to your kernel during boot and see if that helps? It disables some power-saving capabilities. – Arthur Hess May 22 '18 at 6:20
  • @ArthurHess "Could you try passing i915.enable_rc6=0 to your kernel during boot [...]" Mind to explain how can I do that? – Mark Messa May 22 '18 at 6:23
  • @ArthurHess nano /etc/default/grub => GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" => GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_rc6=0" => update-grub – Mark Messa May 22 '18 at 6:28
  • 2
    Assuming you're using GRUB (default on Debian 9, afaik): 1) Reboot your system so you can get to GRUB's menu; 2) With Debian's entry highlighted, press "e" to "edit" the boot parameters; 3) Look for the kernel line (most likely the only one starting with linux /boot/vmlinuz...) and append "i915.enable_rc6=0" to it (strip the quotes). – Arthur Hess May 22 '18 at 6:31
  • 1
    1) I believe you are telling the kernel not to handle display modes (also known as kernel mode-setting[1]), leaving it to user processes (this might explain the lower resolution when disabling this option). I don't believe this is a fix to your problem, as the only thing this does is disable a feature that should be working in the first place; 2) You can edit your /etc/default/grub with this option and run update-grub afterwards, if you really want to make it permanent. --- [1] wiki.debian.org/KernelModesetting#Intel_GfxCards ; – Arthur Hess May 23 '18 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.