0

I updated to mutt 1.10.0 and now my character sets are all messed up. They worked fine with 1.5.21 -- system version and now old. Following the FAQ, I have these set up:

; echo $TERM                                                                    
screen-256color-bce                                                                                               
; locale                                                                        
LANG=en_GB.UTF-8                                                                
LANGUAGE=en_GB.UTF-8                                                            
LC_CTYPE="en_GB.UTF-8"                                                          
LC_NUMERIC="en_GB.UTF-8"                                                        
LC_TIME="en_GB.UTF-8"                                                           
LC_COLLATE=C                                                                    
LC_MONETARY="en_GB.UTF-8"                                                       
LC_MESSAGES="en_GB.UTF-8"                                                       
LC_PAPER="en_GB.UTF-8"                                                          
LC_NAME="en_GB.UTF-8"                                                           
LC_ADDRESS="en_GB.UTF-8"                                                        
LC_TELEPHONE="en_GB.UTF-8"                                                      
LC_MEASUREMENT="en_GB.UTF-8"                                                    
LC_IDENTIFICATION="en_GB.UTF-8"                                                 
LC_ALL= 

UTF-8 character such as Consulat général de France appear fine in less (my pager but also in neovi) but appear as Consulat gM-CM-)nM-CM-)ral de France in the menu.

I do have set config_charset=utf-8 set in my ~/.muttrc.

  • 1
    If you compile/link with ncurses rather than ncursesw it will behave that way. – Thomas Dickey May 21 '18 at 8:12
1

If you compile/link with ncurses rather than ncursesw it will behave that way.

The "M-" prefix is used for character codes 160-255 when the locale settings tell ncurses that the code is nonprinting. UTF-8 contains a lot of those codes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.