-1

I started playing Necromancer from Vulnhub (CTF). It was working just fine. I set the network adapter to bridged mode and I was able to capture every flag up to the point where I had to exploit SNMP. In other words, working as expected. snmpwalker wasn't working the way I expected. A bit of troubleshooting determined that I couldn't even ping the host from my Kali VM or even my main Windows box.

I ran the arp-scan -l from my Kali VM and the IP that displayed on the DHCP lease in OpenBSD appeared in my arp-scan.

However, I do know my ARP list doesn't always update. One of my machines had appeared twice but it's still worth noting.

  • I updated VirtualBox and it's respective extension packs
  • Uninstalled Necromancer VM and deleted all files
  • Re-downloaded the OVA and re-imported into VirtualBox
  • Logged into Router. My Windows box says I have 3 clients running which makes sense (Windows, Kali VM, Necromancer VM)
  • Installed Necromancer as a VM on my 2 laptops. No difference.
  • Switched virtual adapters on all my VM's and Necromancer to Host-Only-Mode with the same adapter and repeated the steps above
  • Brought one of the laptops to a coffee shop router to see if I could ping it. No luck. I can ping myself so there really should be no issue. But then again their router may have settings to prevent it. I don't know I didn't set it up.

What I can infer from this is that it IS connecting and it IS obtaining a valid IP address but something is preventing it from being pinged let alone scanned. Again, this is with MULTIPLE computers on MULTIPLE networks? What can I do to further isolate or resolve this problem? I want to finish the game.

closed as unclear what you're asking by Rui F Ribeiro, G-Man, Thomas, Kiwy, Timothy Martin May 23 '18 at 20:17

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Title says openbsd cannot connect, you end up saying you cannot scan it (and ping?). The text is confusing and too long. – Rui F Ribeiro May 21 '18 at 1:32
  • I literally stated that I could not ping it. You should read more carefully. I placed a solution already. – user21303 May 21 '18 at 1:35
  • I could not not get it to connect to the network. That is what you should have inferred from the title. If you read my post, I concluded that it was not connecting normally because it failed a ping test yet it was seen by my router. It’s very self explanatory. As my solution states, it’s one of those rare occasions where ping is not supposed to work. Take your time when reading. – user21303 May 21 '18 at 1:40
  • 1
    For some of us it is normal to have systems not pinging due to security configs. A machine upon getting an ip address does connect. I would understand v the title if you had not reached the conclusion it was not happening in the v question. Your answer fails to address the problem. I have read this, took time to convey to you it is poorly conveyed, and you have the bad taste of blaming my reading skills. I do not feel the question is particularly good, and I am entitled to my opinion. If you do not want to improve it, do be it. – Rui F Ribeiro May 21 '18 at 2:15
  • 2
    @Debian_yadav Please be careful when suggesting edits. Both roaima and I had to fix text that had incorrectly been formatted as code. – Anthony Geoghegan May 21 '18 at 13:17
2

Ping won’t work on this particular system. I can verify that it works using wireshark. It is broadcasting from UDP port 4444. This is expected behavior as the first mission requires you to listen on UDP port 4444 with netcat.

  • Pings/icmp reply messages can be disabled via firewalling, kernel parameter and/or sysctl – Rui F Ribeiro May 21 '18 at 1:35
  • (it would be interesting finding out why) – Rui F Ribeiro May 21 '18 at 2:01
  • I edited my solution to explain why receiving traffic from port 4444 was an indication that the box was working as intended. – user21303 May 21 '18 at 14:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.