1

Today trying to install GNUHealth on my Fedora 27 (32bit). after creating user I tried to verify PostgreSQL. here's a file pg_hba.conf in /var/lib/pgsql/data. This shows following lines enter image description here

In this file i found no line containing local all all trust

gpg --recv-key 0xC015E1AE00989199 returns this

gpg: directory `/root/.gnupg' created
gpg: new configuration file `/root/.gnupg/gpg.conf' created
gpg: WARNING: options in `/root/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/root/.gnupg/secring.gpg' created
gpg: keyring `/root/.gnupg/pubring.gpg' created
gpg: no keyserver known (use option --keyserver)
gpg: keyserver receive failed: bad URI

gpg --with-fingerprint --list-keys 0xC015E1AE00989199gives

gpg: /root/.gnupg/trustdb.gpg: trustdb created
gpg: error reading key: public key not found

After downloading the detached signatures I tried to verify the package by gpg --verify gnuhealth-3.2.9.tar.gz.sig gnuhealth-latest.tar.gz this too shows

    gpg: error reading key: public key not found

Then I wrote this of installation ./gnuhealth-setup install this returns 2018-05-20 07:08:03 [INFO] Starting GNU Health 3.2.9 installation... 2018-05-20 07:08:03 [INFO] Checking requirements -> Looking for wget... wget is /usr/bin/wget -> Looking for 2to3... 2018-05-20 07:08:03 [ERROR] 2to3 command not found. Please install it or check your PATH variable 2018-05-20 07:08:03 [INFO] Bailing out ! 2018-05-20 07:08:03 [INFO] Cleaning up temp directories at 2018-05-20 07:08:03 [INFO] removing base dir at So I failed in installation. what should be done in this?

0

This is because 2to3 is not installed by default and can be installed by using

yum install python-tools

Now running ./gnuhealth-setup install should allow it to complete

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy