2

I had a FreeBSD 10 installation that booted under UEFI. It's on an AsRock C2750D4I motherboard. Recently I've had the motherboard replaced under warranty and now I can't boot the server automatically.

If I use the boot menu and select the UEFI shell I can change to fs0:/efi/boot and run the bootx64.efI - which then boots successfully into FreeBSD. Any idea what I might need too do to get the server to boot without manual intervention? I'll be upgrading to FreeBSD 11.1 too if that makes things simpler.

  • Just a wild guess, but you can look into gpart bootcode command. – arrowd May 20 '18 at 8:27
  • That didn't work for me, I think the bootcode option is only used for legacy booting. – Mike May 28 '18 at 14:58
0

Does your /efi/boot also contain a startup.nsh file?

Once booted, look at: gpart show

Find the number of the EFI partition: gpart bootcode -p /boot/boot1.efifat -i <that number here> <name of disk, like ada0 or da0>

This will update your EFI boot code with the newer code.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.