0

I have a very strange behaviour with my remote server. First of all, when I access my server with ssh, I sometimes have to enter my password although my user is in authorized_keys. Sometimes it works without password as expected.

Secondly, I tried to unzip an uploaded file inside my home directory, but this didn't work because I got the following exception:

$ 7z x myfile.7z 
sh: 0: getcwd() failed: No such file or directory

7-Zip [64] 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
p7zip Version 9.20 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,1 CPU)

Processing archive: myfile.7z

Error: No such file or directory   

First I thought it has something to do with the file itself and tried to open some files from my Backup directory. As I tried to change into my backup directory, the following happened:

$ cd Backup/
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

what the hell is going on here?

Then I logged out and logged in with ssh again (this time I didn't get the password prompt as expected) and suddenly, all these operations work out of the box. Any ideas about this behaviour?

My suspicion is that this has anything to do with the file system encryption of my home folder:

/home/.ecryptfs/myself/.Private on /home/myself type ecryptfs (rw,nosuid,nodev,relatime,ecryptfs_fnek_sig=c98a7ab1a9b19b23,ecryptfs_sig=a7190210385fa1be,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_unlink_sigs)
  • Are you the only person who can login as the myself user? – muru May 20 '18 at 7:34
  • 2
    You have to login with password to decrypt your partition. – Mikael Kjær May 20 '18 at 7:42
  • When this happens, are you able to list the contents of the home directory, or even verify that you are in your correct home directory? – Kusalananda May 20 '18 at 7:43
  • @muru I'm not sure what exactly you mean. In authorized_keys there is only my local user I use to connect to to my remote server. Otherwise, everybody could login who has the password if the prompt appears. – Bevor May 20 '18 at 8:09
  • @MikaelKjær Ok, does this have any effect on the described problems? I mean, can it be that there is something wrong with the decryption process or anything else? – Bevor May 20 '18 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.