4

Whenever the Ctrl+Shift key combo is pressed, the text ISO 14755 mode text pops up at the corner of the terminal window in urxvt. Is there a way to remove this without having to rebuild urxvt?

I'm using a pre-built version of urxvt in Manjaro Linux (i3wm). I wanted to have the copy and paste binded to Ctrl+Shift+C and Ctrl+Shift+V respectively. I followed this solution and worked. But that's when this problem started occurring.

According to this source, the switch can be solved by adding these two lines to the ~/.Xresources file.

URxvt.iso14755: true
URxvt.iso14755_52: false

However, the mini-dialog still pops with ISO 14755 mode each time I execute copy or paste. Another solution involves removing the iso support before building the package using the ./configure --disable-iso14755, but I would like to solve it without having to reinstall the package.

8

You've disabled keycap picture insert mode but not basic ISO 14755 mode. To disable both, set both to false.

URxvt.iso14755: false
URxvt.iso14755_52: false

After changing ~/.Xresources, reload the file with

xrdb -merge <~/.Xresources
  • Thank you so much for solving it! I surfed all over the place before deciding to make the post. Could you please explain what the last line does? I just did xrdb ~/.Xresources then reloaded the terminal to fix it. What does the -merge flag and the redirection do in this context? – Ébe Isaac May 19 '18 at 9:42
  • @ÉbeIsaac Without -merge, this removes any other X resources that you have. That's all right if you're loading from a file and you always put all your resources in that file, but not if you split them over multiple files or if you add some dynamically or if you're loading more resources during a session. – Gilles May 19 '18 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.