I opened up port 8887 on a server that had it disabled using ufw allow 8887/tcp.

I'm not trying to close it again. I used ufw status numbered to get a list of rules and then ufw delete <NUMBER>.

The problem is that I can still see the web portal on port 8887 when I'm expecting it to be closed.

When I run ufw status I get back:

To                         Action      From
--                         ------      ----
22                         LIMIT       Anywhere                  
2376/tcp                   ALLOW       Anywhere                  
8140/tcp                   ALLOW       Anywhere                  
32793/tcp                  ALLOW       Anywhere                  
9000/tcp                   ALLOW       Anywhere                  
8887                       REJECT      Anywhere                  
8887/tcp                   REJECT      Anywhere                  
22 (v6)                    LIMIT       Anywhere (v6)             
2376/tcp (v6)              ALLOW       Anywhere (v6)             
32793/tcp (v6)             ALLOW       Anywhere (v6)             
9000/tcp (v6)              ALLOW       Anywhere (v6)             
8887 (v6)                  REJECT      Anywhere (v6)             
8887/tcp (v6)              REJECT      Anywhere (v6)   

How can I make sure no one can access port 8887?

closed as off-topic by Jeff Schaller, G-Man, telcoM, Rui F Ribeiro, tripleee May 22 '18 at 6:46

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, telcoM, tripleee
If this question can be reworded to fit the rules in the help center, please edit the question.

  • According to the information you have provided port 8887 is rejecting all traffic. If you use nc -z [host] [port] you can check to see if the port is open. Here is the man page for more info. nmap is a good tool to check if ports are open as well. – kemotep May 18 '18 at 19:35
  • @kemotep according to nc the port is open, as if the ufw rules aren't actually working. – Philip Kirkbride May 18 '18 at 19:41
  • 1
    Odd, I see your answer points out that it was a conflict between your VPS provider's configurations and your firewall. Glad to hear there was a solution, however that is not encouraging that Digital Ocean can leave ports open without your knowledge. – kemotep May 18 '18 at 20:24

This might have been caused by the fact that I was using a pre-configured droplet from Digital Ocean labeled Ubuntu 16.04 with Docker pre-installed.

One of the aspects setup was firewall which allows 2 ports needed by Docker Swarm and 22 for ssh.

I'm thinking when I tried to setup my own firewall settings on the node it some how conflicted with their setup.

I went to the node configuration on the Digital Ocean GUI and was able to add Firewall settings to accomplish what I was looking for.

Not the answer you're looking for? Browse other questions tagged or ask your own question.