5

I usually turn the alert sound (by default a water drop sound) off by going to control-center→Sound→Sound Effects and muting the Alert volume. This is in Gnome.

I wanted to turn it off in a custom live build of Debian by default, but I can't figure where this setting is stored. I tried dconf and looked around config directories extensively without success. I tried find ~ -mmin -1 also gio monitor and inotifywatch without success. The only output by find ~ -mmin -1 was .config/dconf/ and .config/dconf/user which get edited all the time the control center is opened anyway. I replaced this user file in a vm to test and all dconf settings were updated except the one I need (the alert sound). I also tried dconf watch / which gave no output when I tried editing the alert sound setting

I'd like someone to tell me how to mute this setting from command line and possibly tell me where it is stored.

  • That's extremely close, I can't really edit the preferences of the alert sounds from this dconf key but I can completely disable them, which is enough for me. I don't know if the question should be removed as a duplicate though. – cablewelo2ma May 20 '18 at 0:02
6

This can be achieved by this command

dconf write /org/gnome/desktop/sound/event-sounds "false"

However, this doesn't turn off the sound volume slider effect.

To completely turn off the sound effects the closest way I've found was to live boot into a clean iso of the distro and open the System settings > Sound > Sound effects and turn these sounds off as preferred, then copy the file ~/.config/pulse/*-stream-volumes.tdb and save it. Then, to turn off the "sound effects" on an installed environment or while building a custom version of the distro do

cp saved-pulse-volumes.tdb ~/.config/pulse/*-stream-volumes.tdb
  • thanks! to completely turn off i have find all settings by keyword bell. – dzNET Mar 10 at 18:44
0

There is another key you can set with dconf:

dconf write /org/gnome/desktop/sound/input-feedback-sound "false"

which should disable to play sounds on input events.

  • This key doesn't exist in my distro, are you sure this is debian? – cablewelo2ma Jun 27 '18 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.