1

After an update to F28, every time I reboot my machine, the GDM screen is showing an ugly, unnecessary, and useless virtual keyboard instead of the login screen.

How do I disable that?

My login screen looks similar to this one:

enter image description here

The ugly virtual keyboard all over my screen.

Once I remove it, this is what I see:

enter image description here

That screen does not contain any accessibility options.

As as as I know, I installed Workstation ages ago (26, I think), updated to 27, and now to 28.

  • Did you try the accessibility options on the same screen? – Ignacio Vazquez-Abrams May 18 '18 at 15:23
  • @IgnacioVazquez-Abrams There are no accessibility options on the same screen therefore I did not. – Sardathrion May 18 '18 at 15:35
  • What do you mean by "There are no accessibility options"? They are in the menu in the upper right of the login screen. – Michael Hampton May 18 '18 at 17:12
  • @MichaelHampton I know where the options should be. They are not there. All I have is a reboot/shutdown icons. – Sardathrion May 21 '18 at 8:03
2

On screen keyboard driving you mad?

Fedora login screen with on screen keyboard

Get rid of it by clicking the accessibility icon in the upper right.

Fedora accessibility menu], keyboard on

You can then select "Off" for the keyboard.

Fedora accessibility menu, keyboard off

  • This is no what I see at all… First, the login screen looks like this, the keyboard is full screen hiding the rest, and there are no accessibility options. – Sardathrion May 21 '18 at 7:56
  • @Sardathrion You appear to have installed a Fedora spin (but not mentioned this important detail). In that case this answer is not going to help you. You may wish to edit your question further. – Michael Hampton May 21 '18 at 13:04
  • As far as I know, I am on Workstation… – Sardathrion May 21 '18 at 13:21
  • @Sardathrion That's not Workstation, and that's not GDM. The image you posted is from Fedora LXQt spin. – Michael Hampton May 21 '18 at 13:22
  • Okay… The screen shot is not what I am seeing but is more what I am seeing that yours. This is an updated machine from 26 via 27 which was a workstation. I shall post an accurate screen shot tomorrow when I can access the machine in question. I am not meant to sound annoyed at you, I am just really annoyed at this change of behaviour for no damned good reasons whatsoever. – Sardathrion May 21 '18 at 13:28
1

Based on musings by Michael Hampton, I tried to make sure that I was running gdm and not some other manager. I installed system-switch-displaymanager via

sudo dnf install -y system-switch-displaymanager

and ran system-switch-displaymanager gdm. Then, verified that it was running:

sudo systemctl status gdm.service                                            
● gdm.service - GNOME Display Manager                                          
   Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset:>
   Active: active (running) since Tue 2018-05-22 14:16:48 BST; 4min 28s ago
 Main PID: 1341 (gdm)
    Tasks: 3 (limit: 4915)
   Memory: 9.3M
   CGroup: /system.slice/gdm.service
           └─1341 /usr/sbin/gdm

I am now seeing what this answer shows and no ugly on-screen keyboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.