5

I've recently reinstalled CentOS onto a computer of mine. I have OpenSSH Server on it now, as did I before I reinstalled the operating system.

Here's the difference: Before, SSH started without even having to login to an account. Now, it seems like I have to login to an account on the machine before being able to remotely connect via SSH.

Can anyone help? I tried using chkconfig, but that didn't appear to do anything differently.

4
  • Does your computer connect via wireless? Perhaps managed by gnome-network-manager ?
    – squareborg
    Aug 1, 2012 at 11:14
  • @shutupsquare - yes, actually that's the only difference. This install it's wireless, before it was a wired internet connection. I am still connecting from another computer on the network though. What do you suggest I do?
    – DannyF247
    Aug 1, 2012 at 11:15
  • answered below pal.
    – squareborg
    Aug 1, 2012 at 11:18
  • @DannyF247 if you go to network manager on your desktop session and edit the wireless connection, is the checkbox "available for all users" checked? It might be needed for your purpose.
    – tripledes
    Aug 1, 2012 at 11:19

1 Answer 1

4

Your wirless will be managed by Gnome Network manager, this will only start at login, You would be much better using wpa_supplicant to start your wireless at init. There is a nice tutorial here

8
  • 1
    Firstly, thanks. I did that all successfully, except Edit /etc/sysconfig/network-scripts/ifcfg-*. There were no existing files in /network-scripts/ that ended with eth0, eth1, or wlan0 (I need wlan0 in my case). Any help?
    – DannyF247
    Aug 1, 2012 at 11:33
  • 1
    If there is none just create it for your interface.
    – squareborg
    Aug 1, 2012 at 11:38
  • Alright, done. Still not connecting - when I ping it returns destination host unreachable. Is there any way I can "debug" this and see if its giving any error at startup?
    – DannyF247
    Aug 1, 2012 at 11:48
  • What runlevel do you start in, do you boot straight to GUI login?
    – squareborg
    Aug 1, 2012 at 11:54
  • Anyways you need to paste me the output of dmesg tail the last 100 lines
    – squareborg
    Aug 1, 2012 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.