1

I have an awkward screen resolution problem and I can't figure out the problem.

My xsession (xfce/debian on a laptop, I am the only user, lightdm autologged in, a setup with 2 additional monitors) seems to open more or less randomly in two different states regarding screen resolution. The most visible symptom is the size of the fonts in my xterm/gnuscreen window. Here are the links to two screenshots (exactly the same size) showing this:

First state(I called it bad, it's only not the one I want) :

Second state(the good one, the one I want) :

Problem is the xdpyinfo output is exactly the same in both cases :

fmeyer@ganymede:~$ diff goodsmall badlarge    
fmeyer@ganymede:~$

xdpyinfo :

http://perso.utinam.cnrs.fr/~fmeyer/screenres/badlarge

http://perso.utinam.cnrs.fr/~fmeyer/screenres/goodsmall

The Xorg logs do not show anything obvious, a grep -i dpi in them is inline here :

http://perso.utinam.cnrs.fr/~fmeyer/screenres/grepiDPI_Xorg_output

Ideally, I am searching for a way to fix this randomness in a way or another.

Less ideally, I am looking for a way to identify in which state the server is so I can script the adjustment of my xterm font size.

Any idea on what is happening here and where it is happening?

EDIT: Summary of ideas, attempts and their outcome as of 20180518_0950UTC :

  1. made sure that xrandr outputs (not only modes but also verbose outputs) were identical in both cases. Checked.

  2. made sure that xdpyinfo outputs were identical in both cases. Checked.

  3. made sure xterm was allways called with same geometry, font and fontsize, checked.

  4. made sure the problem also appears in single monitor configuration ; same outcome, checked

Symptoms are blatant in single monitor screenshots (badgood) and tells why I tagged first state as "bad".

EDIT #2 Question unanswered but problem solved : I replaced the lightdm autologin with a getty autologin + startx from .bashrc and it seemingly solved the issue.

So the original problem seems to arise from an obfuscated conflict/race/your_guess between lightdm and the X server. I wont investigate further, unless someone reading this wants to track down the issue to its very origin. Thanks to dirkt for his help ruling out some potential causes.

  • Are you sure the resolution is different? Can you e.g. start some X applications that support -geometry to verify they indeed are placed differently? Things that can be different with the same resolution: (1) Fonts chosen, (2) possible additional scaling by video driver. So try xfontsel with a fully specified font, and xrandr. – dirkt May 17 '18 at 14:33
  • I am not sure the resolution is different (in fact I am not sure of much, that's why I sticked to the symptom in the description) ; but in both cases, the xterm command that leads to the screenshots is the same "nohup xterm -geometry 237x72 -fa "Bitstream Vera Sans Mono" -fs 12 -e 'screen -c $HOME/.screenrc_init'" and it produces the two different results you can see in the screenshots. So, something must be different between "bad" and "good" but I cant figure out what nor why. – eul'dulle May 17 '18 at 15:07
  • Still, the modes are set at session start by xrandr calls from a script with hardcoded modes so I am pretty sure the modes of xrandr are the same in both screenshots, and that is why I suspected a dpi mess somewhere. – eul'dulle May 17 '18 at 15:43
  • But the DPI is the same in both xdpyinfos. So definitely look at the rest of the xrandr --verbose output, not only at the modes. Newer GPUs/drivers have an additional scaling feature. – dirkt May 17 '18 at 16:59
  • ok, makes sense. Did that, but only timestamps: lines differ :( (badxrandrverbose and goodxrandrverbose available at the same url). – eul'dulle May 18 '18 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.