I have just installed linux mint 13 and I haven't used linux before so I apologise upfront if this question seems basic. I am unable to hear any form of audio on file which I try to play in any "media playing" application but I am not sure why.

When I log onto the system I get the start-up sound (before entering login details). I can hear audio from my speakers if I right click the speaker icon, select "Sound preferences" > Hardware > select my speakers from the device list and click test speakers. I am also able to hear audio on sites such as youtube.

I have run this command

lspci -v | grep -A7 -i "audio"

and I got two results returned as follows:

00:1b.0 Audio device: Intel Corporation X79 series chipset High Definition Audio Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 84f8
Flags: bus master, fast devsel, latency 0, IRQ 112
Memory at fa720000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel

02:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)
Subsystem: Giga-byte Technology Device 3515
Flags: bus master, fast devsel, latency 0, IRQ 28
Memory at fa080000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel

Which I think means my sound card (which is integrated on a Rampage IV Extreme mobo) should be ok.

What I think might be happening is that the applications such as VLC, Banshee, Totem movie player etc might be reading the default audio output device from a different place than the mint install itself is. I am basing this on the fact that when I first installed the system a week or so ago no sound would play and I had to go to Sound preferences > Output and select my speakers from the list as the default choice was "Built-in Audio Analogue Stereo", once I made this change system sounds would play but not any media files such as songs or movies. Therefore I reckon that maybe the applications are still trying to output audio through the "Built-in Audio Analogue Stereo" instead of my speakers.

This is driving me a little bit insane now and any help would be greatly appreciated. My theory is just a theory (I have no previous experience using linux) so any ideas or suggestions are welcome. If any more information is needed, let me know and I can provide it.

2 Answers 2


Ok so whilst I have managed to sort this out now, I used the information presented in this link to fix my problem: http://www.linuxandlife.com/2012/05/no-sound-in-linux-mint-13-maya.html

I just downloaded and installed Linux Mint 13 Maya ( the MATE edition) today and I think I really like it. However, one problem occured that when I tried to play some music with Banshee, there was no sound at all. ( Although the login sound still worked)

I check the sound preferences and found that due to some reason, Linux Mint picked the wrong sound output hardware in my laptop ( a Sony vaio E series). It should be the "Built-in Audio Analog Stereo" option ( the first one that got highlighted) instead of the HDMI option.

To make the sound work again, you just need to select the first option then close the sound preferences.

However, this solution only works temporarily. After rebooting my laptop, the problem happened again. This time, I used another method that fixes the problem permanently. To get the sound to work after login without editing the sound preferences, you just need to restart pulseaudio when booting up. This can be done easily by adding some simple commands to the startup applications.

Go to the Linux Mint menu, search for " Startup Applications". When the Startup Applications Preferences window open, click on the "Add" button then add the following command into the command section: rm -rv ~/.config/pulse && sudo killall pulseaudio

Give it a name then click the +Add button then close the Startup Applications Preferences window. It should look like this

And that's it. From now, the sound works like a champ in Linux Mint 13.

I have quoted the content from the site, but if you have trouble it is worth going to the site as it contains screenshots to accompany the instructions.


I had problem too. It turns out the solution is simple. go to preferences>sound>output and turn off the HDMI output

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .