1

I run Debian 9 with LXQt what is completely fine. However, attached USB-volumes are not getting displayed in the PCManFM-Qt sidebar in category Devices intended for that (see screenshot).

Which package is responsible for that?

I activated all three necessary options in Preferences -> Volume, but the drives still don't appear in the sidebar. Ironically the taskbar-widget shows the drives and I can easily open them in PCManFM-Qt by clicking on the widget. However they are never displayed in the sidebar while the category Devices remains completely empty. During common workflows that is a bit uncomfortable...


Screenshot of the issue:

Empty "Devices" category when USB-device is plugged in

Screenshot of the working taskbar widget:

Working taskbar widget that opens the displayed device in <code>PCManFM-Qt</code> correctly

Again, clicking on the taskbar widget the device gets opened in PCManFM-Qt without any problems. Only displaying its existence in the sidebar does not work.

2
  • Have to tried with terminal?
    – Siva
    Commented May 16, 2018 at 13:23
  • @SivaPrasath: Excuse me, I don't understand what you mean. How can I try it in terminal?
    – Dave
    Commented May 16, 2018 at 14:10

2 Answers 2

0

Merely the package gvfs-backends was missing. This package is responsible for virtual filesystems in userspace.

After installation everything works fine!

0

Getting usb devices to show up in thunar is messy but here is the process no matter your system configuration:

  1. Dbus and Xdg stuff must be installed.
  2. XDG_SESSION_TYPE=x11 dbus-run-session openbox-session or gnome-session (you run that in tty or put in xinitrc + startx) This loads your display environment. If you have a login or display manager, it takes care of this step. It is insufficient to run openbox-session since Xdg and dbus are needed as well. 3 things run in that command. Session type can be Wayland if compositor supports Wayland. Openbox does not.
  3. Thunar, thunar-volman and udevil must be installed computer restarted.
  4. Udevil daemon thus ( udevil &) must run for a few seconds then good to launch thunar, volume management should be enabled; restart thunar if you just enabled.

Zero need for Gvfs. You can replace udevil with bloated Gvfs if you want. Also better to thunar --daemon on startup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .