2

Boot time framebuffer/amdgpu driver load

The issue: switching over from Radeon kernel driver (radeon.ko) over to Amdgpu (amdgpu.ko).

I was able to get up to the point where it seems to load the amdgpu as seen in the boot screen, but it it stops going any further from that point on.

The only change made to the system was blacklisting the radeon driver:

 /etc/modprobe.d/blacklist-radeon.conf:

 blacklist radeon

I've even checked driver support for the device by doing:

$ lspci -k|egrep 'VGA|in use'

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8400 / R3 Series]

Kernel driver in use: radeon

Kernel modules: radeon, amdgpu

$ lspci -n |grep 00:01.0

00:01.0 0300: 1002:9830

Where:

00:01.0 – Device

1002 – Constructor code for AMD/Radeon Corporation

9830 – The model ID.

Then to search the driver using the model id:

$ cat /lib/modules/4.13.0-41-generic/modules.alias|grep 9830

alias pci:v00001002d00009830svsdbcsci* radeon

alias pci:v00001002d00009830svsdbcsci* amdgpu


The only other method I've tried was installing amdgpu-pro 18.10 drivers from AMD https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-Release-Notes.aspx (Which automatically blacklists radeon for you and sets up a udev rule for all user access to /dev/kfd for the video group.

Which amongst other things installs a dkms amdgpu module. And I've also made these changes to kernel boot time:

 GRUB_CMDLINE_LINUX_DEFAULT="amdgpu.cik_support=1 radeon.cik_support=0  amdgpu.vm_fragment_size=9"

Yes, linux kernel 4.13.0-41-generic has CONFIG_DRM_AMDGPU_CIK=y enabled.

And yet this still doesn't work. So I'm not sure what else I'm missing or not doing. Hopefully someone can get this resolved.

The whole reason I have even gotten into this is because on configuring X server X -configure and trying to run a OpenCL application I get the message:

amdgpu_device_initialize: DRM version is 2.50.0 but this driver is only compatible with 3.x.x

  • Okay, but what version of libdrm is installed? – Ignacio Vazquez-Abrams May 16 '18 at 7:12
  • This isn't about the libdrm version, it's actually about the driver version, see here: amdgpu has version 3.1.0: github.com/torvalds/linux/blob/… and radeon has version 2.43: github.com/torvalds/linux/blob/… I need to switch the loaded driver from amdgpu to radeon. – cryptoboy May 17 '18 at 5:19
  • I've been doing a lot of digging around, and seems linux kernel 4.13.0 doesn't have driver support I think for my card. So I tested kernel 4.16.0-041600-generic, which loaded the amdgpudrmfb driver along with amdgpu. Also to get x server working I had to add some device specific settings for the amdgpu in xorg.conf after doing X -showopts in console TTY1 (ctrl+alt+F1) – cryptoboy May 17 '18 at 5:24
  • Additionally and I'm not sure if it was already blacklisted but I noticed in /etc/modprobe.d/blacklist-framebuffer.conf that radeonfb was blacklisted. I was thinking maybe the amdgpu-pro package did that ? – cryptoboy May 17 '18 at 5:26
  • I figured out why it stops booting past the point of loading the amdgpudrmfb, as seen in the image I posted, due to the fact I needed to pass to the kernel the following parameters: GRUB_CMDLINE_LINUX_DEFAULT="radeon.si_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 radeon.cik_support=0" However, this goes to a blank screen, until I put in the xorg.conf configuration, which then everything loads fine. – cryptoboy May 17 '18 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.