1

I have running a Lenovo X270 running with the latest Debian Stretch x64.

I try to get my 4G connection up, but without success for now.

The modem device is recognized and it finds my provider network.

Sending and receiving SMS works fine.

I think pppd does not get an IP assigned.

Here is a log from nmcli c up

May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8230] device (ttyACM0): Activation: starting connection '1&1 Mobile Broadband' (52246f12-b4b7-4f1a-ae5f-cabba1d13c3b)
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8232] audit: op="connection-activate" uuid="52246f12-b4b7-4f1a-ae5f-cabba1d13c3b" name="1&1 Mobile Broadband" pid=3280 uid=1320609664 result="success"
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8233] device (ttyACM0): state change: disconnected -> prepare (reason 'none') [30 40 0]
May 15 16:06:47 nb01194 NetworkManager[620]: <warn>  [1526393207.8708] device (ttyACM0): ip-ifname: set ifname 'ttyACM0', unknown ifindex
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8710] device (ttyACM0): state change: prepare -> config (reason 'none') [40 50 0]
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8712] device (ttyACM0): state change: config -> ip-config (reason 'none') [50 70 0]
May 15 16:06:47 nb01194 NetworkManager[620]: <warn>  [1526393207.8713] device (ttyACM0): interface ttyACM0 not up for IP configuration
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8713] (ttyACM0): using modem-specified IP timeout: 20 seconds
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8716] ppp-manager: starting PPP connection
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8745] ppp-manager: pppd started with pid 3286
May 15 16:06:47 nb01194 pppd[3286]: Plugin /usr/lib/pppd/2.4.7/nm-pppd-plugin.so loaded.
May 15 16:06:47 nb01194 pppd[3286]: nm-ppp-plugin: (plugin_init): initializing
May 15 16:06:47 nb01194 pppd[3286]: pppd 2.4.7 started by root, uid 0
May 15 16:06:47 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
May 15 16:06:47 nb01194 pppd[3286]: Using interface ppp0
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.8900] manager: (ppp0): new Generic device (/org/freedesktop/NetworkManager/Devices/11)
May 15 16:06:47 nb01194 pppd[3286]: Connect: ppp0 <--> /dev/ttyACM0
May 15 16:06:47 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.9082] devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
May 15 16:06:47 nb01194 NetworkManager[620]: <info>  [1526393207.9087] device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
May 15 16:06:47 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 6 / phase 'authenticate'
May 15 16:06:47 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 8 / phase 'network'
May 15 16:07:08 nb01194 NetworkManager[620]: <warn>  [1526393228.5987] ppp-manager: pppd timed out or didn't initialize our dbus module
May 15 16:07:08 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 10 / phase 'terminate'
May 15 16:07:08 nb01194 pppd[3286]: Terminating on signal 15
May 15 16:07:08 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
May 15 16:07:08 nb01194 NetworkManager[620]: <info>  [1526393228.5996] device (ttyACM0): state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
May 15 16:07:08 nb01194 NetworkManager[620]: <info>  [1526393228.6010] policy: disabling autoconnect for connection '1&1 Mobile Broadband'.
May 15 16:07:08 nb01194 NetworkManager[620]: <warn>  [1526393228.6019] device (ttyACM0): Activation: failed for connection '1&1 Mobile Broadband'
May 15 16:07:08 nb01194 NetworkManager[620]: <info>  [1526393228.6041] device (ttyACM0): state change: failed -> disconnected (reason 'none') [120 30 0]
May 15 16:07:08 nb01194 pppd[3286]: Connection terminated.
May 15 16:07:08 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 11 / phase 'disconnect'
May 15 16:07:08 nb01194 gnome-shell[715]: JS LOG: Removing a network device that was not added
May 15 16:07:08 nb01194 NetworkManager[620]: <info>  [1526393228.6476] devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
May 15 16:07:08 nb01194 gnome-shell[1274]: JS LOG: Removing a network device that was not added
May 15 16:07:09 nb01194 pppd[3286]: nm-ppp-plugin: (nm_phasechange): status 1 / phase 'dead'
May 15 16:07:09 nb01194 pppd[3286]: nm-ppp-plugin: (nm_exit_notify): cleaning up
May 15 16:07:09 nb01194 pppd[3286]: Exit.
  • ip-ifname: set ifname 'ttyACM0', unknown ifindex I see this as well. Yet the file is there when I ls /dev/ttyACM0. This is odd, I tried numerous times without success but now it works. – Rolf May 30 '18 at 13:28
  • I have the same issue on Debian stretch with ThinkPad X270. If anyone knows the problem, please help. I'll set up a bounty. – Dominik Schürmann Jun 25 '18 at 23:06
  • If you are using a USB Dongle that does dialup, you will propably need the following packages: netbase ifupdown ppp. If your USB dongle is one of the ones that works with cdc_ether (eth devices over usb protocol) you will probably need the usb_modeswitch ... – user34720 Jun 29 '18 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.