1

My system has a three monitor setup:

  1. Monitor 1 connected to the onboard i915 chip
  2. Monitor 2 & 3 connected to a Radeon RX 560 GPU

This configuration worked until I upgraded CentOS to the 3.10.0-862.2.3.el7.x86_64 kernel.

After the kernel upgrade only Monitor 1 (attached to the onboard i915 controller) is working. Monitor 2 & 3 aren't receiving a signal.

The output of lshw shows the Radeon display as -display UNCLAIMED.

 $ sudo lshw -c video                        
  *-display                 
       description: VGA compatible controller
       product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:38 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Baffin [Radeon RX 550 640SP / RX 560]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:02:00.0
       version: cf
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller cap_list
       configuration: latency=0
       resources: memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:f7b00000-f7b3ffff memory:f7b40000-f7b5ffff

lspci | grep VGA shows both the onboard GPU and the Radeon:

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560] (rev cf)

lsmod | grep radeon returned nothing so I created /etc/modules-load.d/radeon.conf to load the module at boot. The output of lsmod | grep radeon is now:

i2c_algo_bit           13413  3 i915,amdgpu,radeon
drm_kms_helper        176920  3 i915,amdgpu,radeon
ttm                    99555  2 amdgpu,radeon
drm                   397988  9 ttm,i915,drm_kms_helper,amdgpu,radeon
i2c_core               63151  8 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,amdgpu,radeon,videodev

The radeon module now loads during the boot process but lshw still outputs -display UNCLAIMED and the connected monitors still receive no signal.

0

I found the beta version (18.20-579836, released 2018-05-08) under the enterprise radeon pro sections of the main download page. It specifically boasts RHEL 7.5 support.

https://support.amd.com/en-us/download/workstation?os=Linux+x86_64#beta

It took me a while to realize that I had upgraded to CentOS 7.5, and that the old drivers explicitly state support for 7.4. During that time I had tried to go from amdgpu 17.50-511655 to 18.10-572953, but that was giving: amdgpu dkms failed for running kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.