When using less or git log, about the first 30+ lines are missing. I'm using GNU screen in a 2x2 grid, less is running in the bottom right pane.

tput lines returns 65, but that's the total number of lines on my actual terminal, not the number of lines in the GNU Screen pane.

How do I fix this?

  • Are the lines of the document that you are trying to view very long and wrapping? Does more work (in place of less)? – Kusalananda May 15 '18 at 5:57
  • Sounds like something isn't setting $lines appropriately. – Jeff Schaller May 15 '18 at 18:36
  • How are you opening your desktop environment, and what terminal window do you have open for the less/screen commands? – Jeff Schaller May 15 '18 at 18:37
  • I'm on a MBP running Terminal. – Seán Hayes May 16 '18 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.