5

systemd ships the systemd-analyze command which has a verify function that allows you to check the syntax of a systemd unit file.

However, when I ran it today using systemd v238, I get a message back that a disk file system was attmpted to be deleted. What's going on?

$ sudo systemd-analyze verify /etc/systemd/system/my.timer
Attempted to remove disk file system, and we can't allow that
7

This behavior is due to a bug in at least systemd 237 and 238.

From the bug report:

systemd-analyze creates a directory named /tmp/systemd-temporary-XXXX. /tmp is a real, physical directory on my machine

when rm_rf_children is called, for manager cleanup, it has a safety that prevents it from removing physical files unless explicitely told to do so.

While the diagnostic message is scary, it is thankfully about a temporary directory, not telling you that it tried to do rm -rf /.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.