0

Most KDE applications won't accept accented characters, showing instead ���. This happens in Kate, Konsole and Dolphin (although not in Konqueror; nor in Chrome, LibreOffice, etc).

The fonts support accented characters as I can past a test sample (such as "áááÀ���") and is shown correctly.

> locale
LANG=pt_PT.UTF-8
LANGUAGE=en_US
LC_CTYPE=pt_PT.utf8
LC_NUMERIC=pt_PT.utf8
LC_TIME=pt_PT.utf8
LC_COLLATE=pt_PT.utf8
LC_MONETARY=pt_PT.utf8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=pt_PT.utf8
LC_NAME=pt_PT.utf8
LC_ADDRESS=pt_PT.utf8
LC_TELEPHONE=pt_PT.utf8
LC_MEASUREMENT=pt_PT.utf8
LC_IDENTIFICATION=pt_PT.utf8
LC_ALL=

EDIT (after replies) :

I'm using Debian 9.4 (Stretch) with KDE Framework v.5.28.

  • kde-l10n-pt package is installed
  • System Settings > Regional Settings > Language is set to "American English" (I prefer to see messages and dialogues in English)

I added a few locale's while trying to fix this issue:

>locale -a
C
C.UTF-8
en_US
en_US.iso88591
en_US.iso885915
en_US.utf8
portuguese
POSIX
pt_PT
pt_PT@euro
pt_PT.iso88591
pt_PT.iso885915@euro
pt_PT.utf8

And with dpkg-reconfigure locales I set the language to "en_US.UTF-8 ".

1

So apparently this is a bug in qt/kde. Details in the KDE bug tracker and QT bug tracker

As a workaround, the suggestion is to install ibus:

apt-get install ibus ibus-qt4 ibus-gtk3 ibus-gtk 

(I installed all 4 packages, so I'm not sure if they are all necessary)

Don't forget to logout and in again.

0

You should check why you have "en_US" in the LANGUAGE variable. That might be causing some trouble.

I don't know which distribution or KDE version you are using (you should add that information to your question), but you can set locale settings in KDE:

Go to System Settings, you should find the Regional Settings, and select the Language you want there (might need to download a l10n package, like kde-l10n-pt). If you want the applications also in you language you should download the language-pack-kde-pt

Also, make sure you have the locale you want as default.

Verify with locale -a the installed ones, and if using a Debian based distribution (Ubuntu for ex.), set the default locale with:

dpkg-reconfigure locales

And select all the UTF8 locales you want and the Default for the system settings.

  • Thanks @Leo. I should have been more thorough in the description of my previous steps to resolve this issue. I hope my edits correct that. – Fernando César May 14 '18 at 22:37
  • I don't know which characters you are trying to see, but for the record, I'm seeing the square with the question marks too in your post. Here is the screenshot: screenshots.firefox.com/8eM2wjthzpK6b2KZ/unix.stackexchange.com I'm using en_US.UTF-8 and es_AR.UTF-8. As I said above, using en_US (plain, no utf8) as LANGUAGE, might be your issue. You could try setting the 3 variables in .bashrc: export LC_ALL=en_US.UTF-8 export LANG=en_US.UTF-8 export LANGUAGE=en_US.UTF-8 – Leo May 15 '18 at 5:12
  • "áááÀ���" The squares with the question mark are supposed to be "áááÀ", but in Kate or Konsole they turn into that. I tried export LC_ALL=en_US.UTF-8; export LANG=en_US.UTF-8; export LANGUAGE=en_US.UTF-8;. Is this supposed to work by just typing and enter? Because it didn't... Thanks for your time!!! – Fernando César May 15 '18 at 21:46
  • No. It might not work if you just type it. You should place it in ~/.bashrc , logout & login for it to work reliably. I see the áááÀ alright in my konsole. Does locale still show LANGUAGE=en_US? – Leo May 17 '18 at 2:20
  • That didn't work. :( – Fernando César May 26 '18 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.