0

I did try build Docker container, Internet resources access only via proxy. I did set proxy connection for Docker. Did use method 2

After did check this command

[root@server01 docker]# systemctl show docker --property Environment
Environment=HTTPS_PROXY=https://user1:password1@ourproxy:1001/

Did try build Docker conteiner and did retrun error

[root@server01 newapp]# docker build -f Dockerfile -t newapp .
Sending build context to Docker daemon  40.45kB
Step 1/32 : FROM python:2.7
Get https://registry-1.docker.io/v2/: net/http: TLS handshake timeout

How solve this problem?

0

If you are using a private registry, you need to place the certificate for that under /etc/docker/certs.d/registryname/ca.crt

registryname will change accordingly

Also, please change your MTU size to 1300, this was also one thing I did to resolve the error. Registry one I believe you might have already done. Command for MTU change

ip link set dev eth0 mtu 1300

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.