2

I am attempting to install Ubuntu 17.10.

What's happening:

  • I turn on PC
  • Get a message that I can't read in time, something along the lines of: System BootOrder not found. Initializing defaults.
  • PC restarts
  • Endless loop

What I've tried:

What I done leading up to this:

  • PC was originally a Windows 10 install
  • I removed Windows 10 to try Arch Linux
  • I am now trying to install Ubuntu deleting my old Arch Linux installation

I believe I've messed up my booting and I am completely unsure how to fix it. Boot info asks me to change the path for the .efi file but I can't figure out how to do that. Running ThinkPad 470s.

0

BootOrder is one of the UEFI boot variables, stored in NVRAM along with other firmware configuration (what used to be "BIOS settings").

In Linux, you can use efibootmgr -v to view the boot variables.

Example:

# efibootmgr -v
BootCurrent: 0001
Timeout: 6 seconds
BootOrder: 0001,0002,0000,0003,0004,0005,0006
Boot0000* debian        HD(1,GPT,4fb8aadb-9507-44b5-8cab-a052a0091e2b,0x800,0x100000)/File(\EFI\DEBIAN\GRUBX64.EFI)
Boot0001* rEFInd Boot Manager   HD(1,GPT,4fb8aadb-9507-44b5-8cab-a052a0091e2b,0x800,0x100000)/File(\EFI\REFIND\REFIND_X64.EFI)
Boot0002* UEFI: IP4 Realtek PCIe GBE Family Controller  PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)/MAC(107b447ad398,0)/IPv4(0.0.0.0:0<->0.0.0.0:0,0,0)..BO
Boot0003  UEFI Shell    HD(1,GPT,4fb8aadb-9507-44b5-8cab-a052a0091e2b,0x800,0x100000)/File(\EFI\tools\shell.efi)
Boot0004* UEFI:CD/DVD Drive     BBS(129,,0x0)
Boot0005* UEFI:Removable Device BBS(130,,0x0)
Boot0006* UEFI:Network Device   BBS(131,,0x0)

Here I have a Debian 9 system, with two bootloaders installed: the Debian default GRUB, and the more visually-oriented rEFInd, which I've set as the primary bootloader. I also have the UEFI Shell as a boot option, although that option is currently disabled.

Note that the BootOrder lists the order in which the other BootNNNN options will be tried.

You might have a BootNNNN line that's left over from the Windows or Arch installation. Since the bootloader file it refers to no longer exists, it is going to be useless. You can use efibootmgr -B -b NNNN to delete it: just replace NNNN with the actual BootNNNN number you wish to delete.

  • Thanks for your time, but I just managed to solve the issue – notvita May 13 '18 at 11:19
  • No problem. However, please consider documenting your solution by writing an answer yourself, so that your solution may help others with a similar problem. – telcoM May 13 '18 at 11:30
  • I attempted to but it just got added as a comment on my OP. I followed the exact steps listed in the link for anyone else that runs into this issue! – notvita May 13 '18 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.