0

I am trying to compile ChatScript but I get this error message:

json.cpp:474:23: fatal error: curl/curl.h: No such file or directory

When I try apt-get install curl it says:

curl is already the newest version (7.47.0-1ubuntu2.7).

I also tried to install curl-devel and libcurl but I get:

E: Unable to locate package ...

Why this error happens and how can I fix it? I am using Ubuntu-server 16.04 sunxi-arm7.

1

You need to install one of libcurl4-gnutls-dev, libcurl4-nss-dev, or libcurl4-openssl-dev, depending on which is appropriate (check ChatScript’s documentation and license; if the documentation doesn’t specify this, but the license has an OpenSSL license exception, use libcurl4-openssl-dev, otherwise try libcurl4-gnutls-dev).

In future, you can find this out by installing apt-file and using that:

apt-file search curl/curl.h

(The first time you install it, you’ll need to run sudo apt-file update.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.