1

I've setup a new Ubuntu 18.04 virtual machine using Proxmox. On this new virtual machine I can't get a working Internet connection. The command lshw -C network shows:

root@web:~# lshw -C network
  *-network DISABLED
       description: Ethernet interface
       product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 12
       bus info: pci@0000:00:12.0
       logical name: ens18
       version: 20
       serial: 7e:03:e4:16:f7:72
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139cp driverversion=1.3 duplex=full latency=0 link=no multicast=yes port=MII speed=100Mbit/s
       resources: irq:11 ioport:1000(size=256) memory:c0040000-c00400ff memory:c0000000-c003ffff

The network device isn't linked. I dis/enabled the network device a few times using Proxmox, I restarted the machine many times, I tried all the different models of network devices, and I checked if my CPU supports virtualization (it does).

  • Can you ping the host system? – Hauke Laging May 18 '18 at 23:09
  • Do you have other virtual machines in the same Proxmox node that have working network devices? – Colin 't Hart Oct 5 '18 at 8:31
  • I'm wondering if your Promox installation is configured correctly; you need to have a bridge defined in Promox, and your virtual machine's network interface(s) need to be configured to use that bridge. Alternatively you can use NAT mode. – Colin 't Hart Oct 5 '18 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.