2

I am trying to install FreeBSD 11.1 on AMD based board. But installation fails and the system reboots. This happens repeatedly.

Here is what I am doing:

  1. I have created a bootable USB media with 11.1 memstick image (checksum verified)
  2. I chose USB as my first boot device in my BIOS (Aptio v2.18 - UEFI based)
  3. I see the FreeBSD boot loader menu (giving options for multi user,single user etc.,)
  4. I chose multi-user boot. I see the hardware probe is starting and shortly after that system reboots before I get the "Welcome menu"(which will have the install option). I see a trace flashing before the system reboots (but couldn't capture it).

Note: I see the same behaviour when I try with single user mode (or) safe boot "on". I don't see the option for "ACPI support" in "Boot options menu". So, I assume it's disabled already.

Questions:

  1. Could this be related to BIOS? If so, how? I tried with 10.4 UEFI memstick image also. Same behaviour seen
  2. Is there any way I can capture the hardware probe logs to a file (because it just flashes and reboots) (other than serial console)
  3. Is there any way I can prevent rebooting (if there is a panic) from boot loader prompt? I tried boot_pause set to 1. But when I continue booting, system hangs.

I see a similar issue reported here but the suggested solution doesn't help my case.

Am I missing something here?

  • Welcome to U&L , See this recommendation on FreeBSD handbook – GAD3R May 11 '18 at 10:09
  • 1
    @GAD3R Thanks for your reply. I had attempted that solution to set hint.acpi.0.disabled=1. When I do, it panics saying "running without a device atpic requires a local APIC". From link I understand apic is enabled by default in amd64(in GENERIC). I am trying the 11.1 released image only. So, i believe apic should be there, but it's not the case. So, confused about this solution. – rajeshbems May 11 '18 at 11:01
  • FreeBSD forums may be a better venue for asking these questions. Have you tried asking there? Also, AMD based board is a very general term, what is your specific hardware configuration? – ajeh May 11 '18 at 14:50
  • 1
    @ajeh: Yes, I have a FreeBSD forum post as well for this issue. forums.freebsd.org/threads/… – rajeshbems May 14 '18 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.