0

I followed fdiblen's guide on Arch Linux Installation with a Fully encrypted disk and Btrfs filesystem that uses cryptsetup.

I'm at the bootloader stage where I'm trying to grub-install with these new lines in my /etc/default/grub

GRUB_ENABLE_CRYPTODISK=y
GRUB_CMDLINE_LINUX="cryptdevice=/dev/nvme0n1p3:crpytroot:allow-discards"

And while executing the line

grub-install --target=i386-pc /dev/nvme0n1

I got the error:

Grub-install: error: disk 'crpytouuid/0cebxxxxxxxxxxx' not found

I have tried goolging crpytouuid and strangely I didn't get any useful result.

I went to check my /dev/disk/by-uuid and saw that 0cebxxxxxxxxxxx is indeed the uuid of my third partition nvme0n1p3 (which is where / is).

So I did grub-install again but with --verbose and this is what I get:

img_3815

As you can see in the screenshot grub-install logs that

/dev/mapper/cryptroot is not present.

so that can be where the problem is but doing ls /dev/mapper/cryptroot shows that /dev/mapper/cryptroot exists.

I also tried changing

GRUB_CMDLINE_LINUX="cryptdevice=/dev/nvme0n1p3:crpytroot:allow-discards"

to

GRUB_CMDLINE_LINUX="cryptdevice=/dev/disk/by-uuid/0cebxxxxxxxxxxx:crpytroot:allow-discards root=/dev/mapper/cryptroot"

and got the same error.

  • Your cryptdevice is wrong: you want a space, not a : between the dm-name and the option allow-discards. – jasonwryan May 9 '18 at 23:30
  • @jasonwryan that doesn't solve a thing. still the same error. – Archy Will He May 10 '18 at 3:30
  • Well, it did solve the issue of your cryptdevice line being completely wrong... But you're welcome anyway. – jasonwryan May 10 '18 at 6:12
  • @jasonwryan the parser will just ignore it anyway. it really doesn't change a thing here. – Archy Will He May 10 '18 at 23:06
  • @jasonwryan also can you send me a link to a doc that validate what you have said (i.e. showing that : is the wrong syntax.)? now that will be a lot more useful. – Archy Will He May 10 '18 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.