6

I've got two monitors connected via DisplayPort to the dock. xrandr displays the external monitors as DP1-1 and DP1-2 and the laptop as eDP1.

I set up my monitors with the following in ~/.xprofile:

xrandr --output eDP1 --same-as DP1-1
xrandr --output DP1-2 --right-of DP1-1

This works fine. When disconnecting the laptop from the dock the laptop screen does the right thing, reverting to a single monitor. When reconnecting the laptop DP1-1 shows up, but DP1-2 remains blank. . ~/.xprofile changes nothing, and no error message is printed. I tried reconfiguring using the --crtc option, but all I ended up with were complaints that crtc-1 (or something similar) was not configured correctly. After trying a couple things I got "xrandr: cannot find output 0x46", which I can't find any precedence for.

After reconnecting the monitors have the same names ("DP1-1" and "DP1-2") and both of them are shown as "connected" by xrandr.

11
  • I may not have direct answers but few pointers which I want you to try. 1. (Mons package)[github.com/Ventto/mons] 2. adding hotplug configuration for monitor. and running xrandr when detected.
    – Devidas
    Jun 11, 2018 at 7:26
  • you can try github.com/codingtony/udev-monitor-hotplug. I feel this is better way because this way we can always execute when some device plugged in or out. whereas when we do it using ~/.xprofile it will execute only once on start of x-server. I am not claiming it cannot be done that way. just this is more convinient way to write logic(this is just my personal preferance).
    – Devidas
    Jun 11, 2018 at 7:31
  • Are the monitors named the same after reconnecting them?
    – mattia.b89
    Jun 12, 2018 at 19:52
  • Ok... you are an experienced user, so I think the more likely it is a: new-hardware+double GPU+USB-C+multi-monitor-setup = kernel/driver bug or missing feature -> try to open a bug report
    – mattia.b89
    Jun 16, 2018 at 8:57
  • 1
    So... if I manually set the mode for each display as suggested here, they start working again. Interestingly, I still get the same 'configure crtc failed' error, but the displays come back to life.
    – samuelkf
    May 3, 2019 at 10:30

1 Answer 1

0

In my experience, it sometimes works to issue xrandr --auto after connecting to the dock again. This brings up the external monitor 3 out of 10 times at least. Also logging out and then in brings the monitor back to life.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .