3

I am creating my own regulatory.bin for CRDA on Linux. Using my custom regulatory.bin, I want to be able to create my own hotspot with hostapd for any of the 5GHz, 20MHz or 40MHz BW channels.

I am concerned with 5GHz ( not 2.4 GHz ) and currently have all 20MHz BW channels working. Now I want to get the 40 MHz channels working.

So far, for 40 MHz BW channels, I can only get hostapd to create a hotspot using channels 38 and 46. If I try to go higher than that ( 54,62,102,110,118,126,134,142,151, or 159 ), then hostapd complains that the channels are not in the supported list based on CRDA's allowed channels.

This is correct because the allowed channels printed by hostapd do not include these upper 40 MHz channels.

However, I think it should work because my custom CRDA includes what I thin k are the correct frequencies and BW parameters to include the 40 MHz channels:

country FK:
    (2402 - 2472 @ 40), (30)
    (2474 - 2494 @ 20), (20), NO-OFDM
    (5170 - 5250 @ 80), (17)
    (5170 - 5210 @ 40), (20) 
    (5210 - 5250 @ 40), (20)
    (5250 - 5290 @ 40), (20)
    (5290 - 5330 @ 40), (20)
    (5250 - 5330 @ 80), (23) 
    (5250 - 5350 @ 80), (100 mW) 
    (5470 - 5725 @ 80), (1000 mW)
    (5735 - 5835 @ 80), (30)

When I start hostapd to create my WiFi hotspot, the debugging prints show the following as selectable channels based on my custom CRDA entry:

Allowed channel: mode=1 chan=1 freq=2412 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=2 freq=2417 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=3 freq=2422 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=4 freq=2427 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=5 freq=2432 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=6 freq=2437 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=7 freq=2442 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=8 freq=2447 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=9 freq=2452 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=10 freq=2457 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=11 freq=2462 MHz max_tx_power=30 dBm
Allowed channel: mode=1 chan=14 freq=2484 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=36 freq=5180 MHz max_tx_power=17 dBm
Allowed channel: mode=2 chan=38 freq=5190 MHz max_tx_power=17 dBm
Allowed channel: mode=2 chan=40 freq=5200 MHz max_tx_power=17 dBm
Allowed channel: mode=2 chan=42 freq=5210 MHz max_tx_power=17 dBm
Allowed channel: mode=2 chan=44 freq=5220 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=46 freq=5230 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=48 freq=5240 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=52 freq=5260 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=56 freq=5280 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=60 freq=5300 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=64 freq=5320 MHz max_tx_power=20 dBm
Allowed channel: mode=2 chan=100 freq=5500 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=104 freq=5520 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=108 freq=5540 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=112 freq=5560 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=116 freq=5580 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=120 freq=5600 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=124 freq=5620 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=128 freq=5640 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=132 freq=5660 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=136 freq=5680 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=140 freq=5700 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=149 freq=5745 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=153 freq=5765 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=157 freq=5785 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=161 freq=5805 MHz max_tx_power=30 dBm
Allowed channel: mode=2 chan=165 freq=5825 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=1 freq=2412 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=2 freq=2417 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=3 freq=2422 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=4 freq=2427 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=5 freq=2432 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=6 freq=2437 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=7 freq=2442 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=8 freq=2447 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=9 freq=2452 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=10 freq=2457 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=11 freq=2462 MHz max_tx_power=30 dBm
Allowed channel: mode=0 chan=14 freq=2484 MHz max_tx_power=20 dBm

My hostapd configuration file looks like:

# This is the name of the WiFi interface we configured above
interface=wlan1

# This is the name of the network
ssid=asdfasfd

# The network passphrase
wpa_passphrase=asdfasdf

# Use Settings that work for iOS / Android / Windows
driver=nl80211
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
country_code=FK

hw_mode=a
channel=54

#ieee80211n=1
#ht_capab=[HT40+]

beacon_int=100
dtim_period=2
max_num_sta=20
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wmm_enabled=1
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0
eapol_key_index_workaround=0
own_ip_addr=127.0.0.1

wpa=3
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP CCMP
rsn_pairwise=CCMP

What do I have to do to my CRDA configuration to get the remaining 40 MHz BW Channels with hostapd? Thanks.

0

Nevermind I got this to work - it seems you have to specify [HT40-] in the hostapd configuration as well as the upper 20MHz channel number that is joined with to create the 40 MHz channel.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.