0

I am on a system dual-booting Windows and Debian (usually using the latter), and a recent Windows update appears to have wreaked havoc on the Debian boot system. I managed to boot Windows again, but not Linux. Following online suggestions, I created a Live USB of Ubuntu, and booted from that. Then I have installed and run the boot-repair utility. The utility instructs me to type several lines including

sudo chroot "/mnt/boot-sav/sda6" apt-get purge -y grub*-common grub-common:i386

To which I receive the error

E: Unable to locate package grub-common:i386

I am given to understand the issue may have to do with having UEFI vs BIOS (I believe I have UEFI), but do not understand this well. In any case I have subsequently run the boot-repair BootInfo Summary utility which created the following file http://paste.ubuntu.com/p/N8Z95MwB9p/

Any suggestions on how to fix this issue with boot-repair / the boot system would be greatly appreciated.

Thanks!

--Edit--

In what was probably an ill-advised move, I decided to try once again to solve the issue using online resources. From a Linux live disk I ran the following sudo mount /dev/sda1 /mnt sudo grub-install --boot-directory=/mnt/boot /dev/sda I cancelled the second command partway through with CTRL-C when I saw it was trying to install i386 version. Here is a new pastebin, which I believe to be different (and worse..) than the previous one. https://paste.ubuntu.com/p/ZpCm38wmRc/

--Edit-- As per my comment below, I managed to fix the grub by not using boot-repair and simply reinstalling grub (sorry, I do not remember the exact commands used). Booting Debian still did not seem to work, so I just used Windows for a few days until I had time to work on the problem more. I sat down to work on it today and ... Debian boots fine. Everything is working as normal. I have no idea why it suddenly works (and am a bit afraid that something is wrong behind the scenes), but that's all for now I guess. I will note that in the meantime I disabled Windows Fast Boot (must have been reenabled by the Windows update) so maybe that did the trick, although I didn't see any immediate change. Also I realize that none of this is directly related to the original question about boot-repair, which I did not solve.

  • but do not understand this well... Yes, it show and that's the problem, not understanding you have UEFI, not BIOS, and that fact alone changes a lot of things. In order to understand UEFI and dual-booting with Windows read this: askubuntu.com/questions/221835/… Whatever you've been reading is NOT applicable in UEFI. Next, the good news: – user252181 May 9 '18 at 16:33
  • These articles might be useful for understanding: rodsbooks.com/efi-bootloaders (start right with "principles" and see if it helps). – Michael Shigorin May 10 '18 at 7:31
0

Except for the fact the Windows update changed the boot order, there's nothing wrong with your dual-boot.

Please stop doing things that can't possibly work (but can make it worse), right NOW.

Just open UEFI settings > Boot menu and change the order back to "Debian" (You'll find that instead of "Debian" there's now "Windows boot manager") and it should boot with Grub as before. Boot Debian and do sudo update-grub for good measure.

The reason why you can do this (and don't need any commands or even booting a live session) is due to the UEFI specifications that allow for any and all installed OSes to be booted independently unlike what happened before with the old BIOS/MBR where only one bootloader - typically Grub in a Windows/Linux multi-boot replacing the Windows boot loader - could be installed in the MBR (Master Boot Record). As long as the ESP (EFI System Partition) still has the EFI files for a given OS it should boot. Yours are still there:

/EFI/Boot/bootx64.efi /EFI/debian/grubx64.efi
  • Hello, thank you for your reply! Firstly, I found your two comments, especially "yes it shows" in the first, to be unnecessarily condescending and rude -- I'm very grateful that you are trying to help, but would prefer not to be talked down to. Regarding your answer, I regret to say that it is incorrect, although I take responsibility for insufficiently describng the situation. At the time I originally posted GRUB was not booting at all. I went to the boot menu and switched to Windows in order to use my machine and make the live disk. – ERosenberg May 10 '18 at 16:58
  • From the live disk I reinstalled GRUBx64. The current state of the machine is as follows: The normal GRUB boot menu now appears when I turn it on. From there I can select the Windows boot and everything will work normally. Alternately I can boot Debian in Recovery Mode and it will boot up just fine. However if I try to boot Debian normally it hangs almost immediately. I may post another question about this, since it is a different problem than that listed here. – ERosenberg May 10 '18 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.