0

I am unable to update or install anything via debian 9 template vm. if i have a local .deb then i can install and run it off an AppVM. How to fix the following?

sudo apt update --fix-missing
Ign:1 https://deb.debian.org/debian stretch InRelease
Ign:2 https://security.debian.org stretch/updates InRelease
Err:3 https://security.debian.org stretch/updates Release
  Bad header line
Err:4 https://deb.debian.org/debian stretch Release
  Bad header line
Ign:5 http://deb.qubes-os.org/r4.0/vm stretch InRelease
Err:6 http://deb.qubes-os.org/r4.0/vm stretch Release
  Connection failed
Ign:7 http://packages.microsoft.com/repos/vscode stable InRelease
Err:8 http://packages.microsoft.com/repos/vscode stable Release
  Connection failed
Reading package lists... Done
E: The repository 'https://security.debian.org stretch/updates Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://deb.debian.org/debian stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://deb.qubes-os.org/r4.0/vm stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://packages.microsoft.com/repos/vscode stable Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
  • could you elaborate as to what does not help? Looking at the error message you posted it looks like your sources.list for your debian VM does not have working repositories. Verify that your sources.list or /sources.list.d/ are set up correctly. – kemotep May 10 '18 at 20:15
  • What version of Qubes are you using? Latest 4,0 have changed the way templates work in terms of updates: the template can be launched without network access, and still can be updated using a internal proxy through sys-firewall'. Maybe that is failing. Check if the template is configured to use an proxy (file /etc/apt/apt.conf.d/01qubes-proxy), and disable it by commenting out the Acquire:http` line. Then enable networking on the template and try again. – Pablo Oct 8 '18 at 3:00
1

Check if you have correct repository url's in your sources.list file as described here: https://wiki.debian.org/SourcesList

| improve this answer | |
  • To add on to this answer you can check the version of Debian you are running by using this command: lsb_release -a or cat /etc/debian_version. From there verify that you have the correct sources.list as mentioned by user mariaczi. – kemotep May 8 '18 at 13:03
  • nope really doesnt help – user2290820 May 9 '18 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.